Full restore from backup RRS feed

  • Question

  • I've been searching for hours on this, and I can't seem to find anything similar.  Here's what happened.

    I attempted to upgrade my WSS 3.0 SP2 with a lot of content to MOSS 2007.  I did a full farm backup before the upgrade, but the upgrade failed, and it hosed my site up.  So I'm back to a fresh OS and brand new SP install, and I've run the full restore from Central Admin, but nothing changes.  It says that it completed, but none of my information is showing up.  Is there another step?  This is mission critical data, and they're breathing down my neck to get it back up, but I can't seem to figure it out.


    Any help is GREATLY appreciated!



    Friday, November 5, 2010 4:46 PM

All replies

  • Hi Scott,

    Do you have a SQL or any backup of the Content Dbs?



    Ivan Sanders My LinkedIn Profile, My Blog, @iasanders.
    Friday, November 5, 2010 6:22 PM
  • Only the full farm backup that I performed prior to starting the upgrade process.  I have a few .bak files that seem to reflect the general sizes of some of the document libraries that I had.  So it seems that they should be there, but I'm getting nothing.
    Friday, November 5, 2010 6:25 PM
  • what steps you are performing, could  you please tell us? are you able to get your Central admin site? 

    Basically if its fresh install  then after runing the config wizards you can restore your backup but i am not sure what you are doing?


    here is good blog post for step by step restore: http://blah.winsmarts.com/2007-10-Backup_and_Restore_Strategies_in_MOSS_2007.aspx


    hope this help



    SharePoint administrator, MCTS,MCITP
    Saturday, November 6, 2010 7:00 AM
  • What type of back up do you use for your server in general?

    I mean if you use something like VSS on daily bases and you know where are all of your sharepoints files and folders located then you should be able to simply replace the backup image of those file created by (for example) VSS with what you have got at the moment.


    Monday, November 8, 2010 5:39 AM
  • Here's what I have done so far.  In the Central Admin I performed a full backup and saved it to an external drive.  Then I proceeded to install MOSS 2007 Standard.  After installing for a Single Server and allowing it to use an Embedded SQL server and allowing it to run it's wizards, I accessed the new Central Admin site, and tried to do a restore using the "same" selection, but it complained that I was using filenames that already existed in the DB and would fail out.  So I tried a few other things, and nothing helped.  So I decided to uninstall MOSS and try to go back to WSS 3.0 to get operations back up and running, but then WSS claimed that the DB was from a newer Sharepoint server and must be upgraded.  So I ran Windows Updates and got the version numbers corrected, but now when I do the Full Farm restore and use the "same" selection, it claims that all areas succeeded, but none of my site is back.  I'm stuck here looking at the basic blank new install page.

    Now at this point, I know my backups have my content in them, as I have used the SQL Management Studio to look at the db and verify.  But since it wasn't cooperating, I have wiped my OS and drive, and started over, this time with MOSS 2007 Standard.  I need to get the data from the old site into this new one, but given how nothing has worked so far, I'm at a stand still.

    Does that give enough information to see what I'm working with?  It's been a long ordeal, and there's always a chance I'm forgetting something.  But I appreciate the help and links!

    Monday, November 8, 2010 11:04 AM