locked
No Intellisense for Web.config/App.config files in VS2008 SP1 RRS feed

  • Question

  •  

    I've installed VS2008 SP1 on my WIndows Server 2008 64 bit PC.  When I edit app.config/web.config files I get no intellisense.

     

    When I view the Schemas dialog, it shows DotNetConfig.xsd being used (green check mark), all other schemas are set to automatic (no image in the column).

     

    I've tried creating both console and web applications but neither one seems to load the intellisense.  The intellisense is working for my code files/text editor, but not in the XML editor.

     

    Below is a sample App.Config.  I've tried to invoke intellisense (Ctrl+Space) when my cursor is at the position identified by the X character.

     

    <?xml version="1.0" encoding="utf-8" ?>
    <configuration>
      <X
    </configuration>

     

    Any thoughts on this?  I'd be happy to send any log files produced by VS if given instructions.

     

     

    Saturday, August 2, 2008 3:54 PM

All replies

  •  

    Hello,

     

    Have you found a solution. I got the same problem after i installed SQL SERVER 2008.

     

    it was working fine before on Windows  Server 2008 and Visual Studio 2008 SP1.

    Saturday, August 30, 2008 12:00 PM
  • no.  I'm still having that problem.  Nothing I have tried seems to restore my Intellisense.

     

    Please let me know if you are able to sove this.

     

    Saturday, August 30, 2008 2:36 PM
  •  

    It is not working for me as well.
    Monday, September 29, 2008 6:33 PM
  •  

    Same thing here.  Any update on this?
    Monday, September 29, 2008 6:41 PM
  • Same problem here, (also on a x64 machine)

    Wednesday, October 1, 2008 11:32 AM
  • same here, where did it go? i cannot format the document, nor use intellisense, waaaaa, i have been spoiled by intellisense and i want it back!

     

    Wednesday, October 8, 2008 2:58 PM
  • is everyone who is experiencing this problem using the 64 bit OS or a 32 bit version?

     

    Wednesday, October 8, 2008 3:54 PM
  • Does any one have the solution for this.?? I am also having same problem....

    Tuesday, October 14, 2008 8:30 PM
  • all,

    I was able to find a workaround for this by following these steps:

     

    Add an entry in the File Extension(goto Tools -> Options -> Text Editor -> File Extension) with exension as config and Editor as XML Editor with Encoding

     

    After adding, open your app.config file and select <auto detect> if it asks for encoding.

     

    Hope it helps.

    Sunday, October 19, 2008 3:05 PM
  • Without this workaround, my intellisense has magically reappeared.

    Sorry, but i don't know why.

     

    Monday, October 20, 2008 4:12 PM
  • hi

     

    any workaround not having the web config problem, I got mine on single pc with vista after installing sql server 2008

     

    I can not open any Visual Studio at all, just receive the error message: Visual c# intellisence stopped working.

     

    Mattias


    Wednesday, October 22, 2008 7:41 PM
  • I found the solution that worked, at least for me it did.

    Step 1: I added the File Extension(Tools -> Options -> Text Editor -> File Extension). Enter in the "config" exension and chose the Editor part as XML Editor with Encoding. Then close VS.

    Step 2: I opened up the Visual Studio 2008 Command Line window (Start Menu > All Programs >Visual Studio 2008>Visual Studio Tools>Visual Studio 2008 Command Prompt) and entered at the prompt  devenv /resetskippkgs

    I opened up my project again and there it was, color-coded XML again with Intelisense. I don't know what causes this, but its fixed now.  After adding, open your app.config file, you may have to select <auto detect> if it asks for encoding.

     

    Thursday, July 29, 2010 5:59 PM