CopyFileTransacted creates the last error 6801


  • I wrote a program in which CopyFileTransacted is called.
    I tested the program since a longe time (40 nightly test runs).
    It always worked fine.

    In the last nightly test run the call of CopyFileTransacted produced the following error:

          last error code:            6801
          last error message:      Transaction support within the specified resource manager is not started or
                                          was shut down due to an error.

    I changed almost nothing on the computer and OS, on which the nightly test run is executed.
    The only thing I changed, I used another CF-card onto which I copy the files.
    When checking the CF-card, it was ok; test tools reported no errors for the new CF-card.
    That's why I can't imaging, why this error occurs now.

    Has somebody detailed infos about this error and in which case this error occurs?

    Today I tried to reproduce the error again. But now the program was executed without this error.
    I changed nothing. I just restarted the computer. That's all I did.

    But in the past night the test environment did the same. It restarted the computer almost 1000 times.
    And when the test application (containing the CopyFileTransacted-call)  was executed on the fresh booted
    computer, many time the last error 6801 occurred.

    But not today.

    1.   I have no idea, why I can't reproduce this error.
    2.   And what was the reason for those errors in the last night.

    Has anybody possible answers for those two questions?

    So any infos about the reason, which causes this error, are very welcome.
    Thursday, January 14, 2010 5:19 PM


  • What version of Windows is this (Win7, Vista SP1, Vista)?  If it is Win7 there may be information in the event log that would help diagnose what caused the TxF resource manager to shut down, causing this error.
    Christian [MSFT]
    Tuesday, January 19, 2010 8:20 PM