An error occurred during the installation of assembly 'microsoft.vc80.CRT', Public Key Token="1fc8b3b9a1e18e3b", Type="Win32", V RRS feed

  • Question

  • During installation of iTunes, I receive the following error-


    An error occurred during the installation of assembly 'microsoft.vc80.CRT', Public Key Token="1fc8b3b9a1e18e3b", Type="Win32", Version="8.0.50727.762" HRESULT: 0x8007054F


    Because of this error, Apple Mobile Device Center does not install correctly and will not recognize any iPod.


    I have spoken to Apple regarding the error, and they noted this is a Microsoft error unspecific to their software and cannot offer help. I have searched everywhere I can think of to no avail. Please help!

    Monday, May 5, 2008 3:48 PM


All replies

  • I am running Vista Enterprise 6.0.6000

    Monday, May 5, 2008 3:50 PM
  • Hmmm...you need to install the VC runtime but iTunes should have installed this for you.  I know that you can install C++ Express 2008 which includes the VC runtimes (http://www.microsoft.com/express/download/).  See if that solves your problem.


    Monday, May 5, 2008 8:58 PM
  • Thank you so much for your response Weston!


    I tried to install C++ Express 2008, but recieved the following error "Error 1935. An error occured during the installation of assembly 'Microsoft.VC80.ATL,type="Win32",version="8.50727.762",PublicKeyToken="1fc8b3b9a1e18e3b",processorArchitecture="x86"".

    Please refer to help and support for information"


    So, I did a search for this error on the web and noted others with this problem, but there are so many different "solutions" out there and none seem specific to this problem, I'm not sure how to go about solving this error. Any thoughts?


    Thanks again for your help!!



    Thursday, May 8, 2008 5:00 PM

    Im having the same problem installing itunes. Im getting the same error msg that you are. I was wondering what you did to fix the problem??
    Wednesday, August 20, 2008 2:10 AM

    Is anyone closer to a resolution on this? Because C++ issues, anti-virus software and all sorts of other ideas have been thrown around and I'm no closer than when I began.
    Sunday, August 31, 2008 9:00 PM
  • I started with this error and then my IT guy found out it was due to a problem with Windows Update.  Lo and behold, when I checked on windows update, it had failed nearly every attempted download/installation.  You need to install service pack 1 separately.  After that, you can install Itunes.  If you have trouble fixing windows update, like I did, try these two methods below (I did them both at the same time  )


    Monday, September 15, 2008 2:02 PM
  • it doesnt work i dont believe there is a solution to this problem i tunes does not work on microsoft products at least on windows 7
    Sunday, December 19, 2010 3:29 AM
  • I am having the exact same issue, and @tom56071... I have been running iTunes and windows 7 quite fine until version 10.5..  itunes DO work fine on microsft products and have so for me for years.

    windows updates are off for me, so its not an update issue, this is very very frustrating.


    Sunday, October 16, 2011 12:09 AM
  • I believe this is a .net framework corruption issue. Uninstall all .net frameworks and reinstall them,


    Wednesday, October 19, 2011 4:48 AM
  • IphoneGuy, this is the exact problem I am having. Have you managed to find a solution.

    I am not very technical and finding this a right pain!!!


    Saturday, October 22, 2011 2:15 PM
  • IphoneGuy and MissFoy, having the same problem, was on the phone with Apple tech for over an hour trying to figure this out with no solution. 

    Itunes worked perfect before I downloaded the new 10.5!  so frustrating.  Any help would be appreciated.



    Saturday, October 22, 2011 6:55 PM
  • I had the same problem and spent hours trying to re-install the .Net framework and C++ redistributable. However finally found a solution using system file checker (sfc command). I had to create a repair disk (in Programs > Maintenance) then boot from it and run the command prompt, entering:

    sfc /scannow

    This did not work for me at first, it would say a repair was pending the computer must reboot, but never did anything.

    I eventually ran it again from the command prompt in windows (Run as Administrator) with two extra parameters. I cfan't remember exactly but it was  something like:

    sfc /scannow /winbootdir=c:\ /windir=c:\windows

    Google it and you will find it.

    Thursday, November 10, 2011 10:00 PM