locked
Database error RRS feed

  • Question

  • User789372125 posted
    Hi I just downloaded and installed the TimeTracker application. I get the following error when trying to create a new user:

    "Could not open new database 'C:\SOURCE .NET\TIMETRACKER\APP_DATA\TIMETRACKER.MDF'. CREATE DATABASE is aborted.
    An attempt to attach an auto-named database for file C:\source .NET\TimeTracker\App_Data\TimeTracker.mdf failed. A database with the same name exists, or specified file cannot be opened, or it is located on UNC share.
    File activation failure. The physical file name "C:\source .NET\TimeTracker\App_Data\TimeTracker_log.ldf" may be incorrect.
    The log cannot be rebuilt when the primary file is read-only."

    Any idea what this means? I'm using the .NET 2.0 final release version.

    Thanks in advance.

    Thursday, November 3, 2005 11:51 AM

All replies

  • User-1968411731 posted

     Hi

       Just look into your Data folder ,the Log with the name might not be existing.

      The LDF fiel must be there with some other name like databasename_1 etc.

      Just rename the LDF file to database_log. and it should work.

    Thanks and Regards 

    Prasoon.

    Wednesday, June 3, 2009 10:50 AM
  • User555306248 posted

    The error message indicates that either the database file you are trying to attached has already been attached in sql express or there is data corruption in your database file(.mdf file) , thus the db file could not be attached. I would suggest you connect to your sql express server through management studio to make a verification (Note here that since Sql Express use customer instance, in management studio, you must login using the same account as the one you used in your application). If that db file has been attached, detach it and take another try.

    If there is no such file attached already in your sql express, I would suggest you first attach that mdf file to your database. If you still get this error, it means that the mdf file is data corrupted (information in ldf file and mdf file does not match) and cannot be used anymore---You need to restore it then.

     Hope my suggestion helps

    Wednesday, June 3, 2009 10:56 PM
  • User555306248 posted

    Can you please update the status

    Sunday, June 14, 2009 10:57 PM
  • User555306248 posted

    If you solved the error then please mark the answer for the post that helps you

    Monday, June 15, 2009 11:03 PM
  • User555306248 posted

     Are you able to create a new user now

    Thursday, August 20, 2009 10:54 PM