none
How to use DbgView on the target computer but avoid transmission of DbgPrint messages from target computer to connected (remote) debugger (WinDbg) RRS feed

  • Question

  • Hi,

    has anybody a solution for this issue?

    I'm having the following problem. I want DbgView on the target computer to show my DbgPrint outputs as DbgView is quite fast and convenient in displaying them.

    But I DON'T want the messages to be transmitted to my connected debugger which I attached in order to hit some breakpoints, as this will slow down my debugger connection a lot.

    All this was working really fine with DbgView on WinXP by unchecking the "pass through" option. But debugging on Windows 7 for example it does not work any more as intended.

    Is there any workaround for this?

    I already tried several things:

    1) Using gflags.exe to enable the option "buffer debug output" which should per documentation not automatically transmit the messages to the debugger but just to a buffer on the target. But in fact there was no change. Debugger was still floadded.

    2) using the regkeys HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Debug Print Filter or setting the kd_XXX_Mask in debugger manually. But this disables the messages completly (also on the target) which is not what I want.

    3) using kdbgctrl.exe on the target to disable debugging and enable auto mode. This does actually not transmit the messages to debugger but still display them in dbgView. Actually what I want. But the drawback making it useless is, that I cannot change breakpoints from my debugger anymore or manually break into the target. So in fact its really useless.


    Any other ideas?
    I would really appreciate help for this topic!

    Thanks already
    Matthias
    Wednesday, March 29, 2017 10:04 AM

All replies

  • Don't use DbgPrint, instead use WPP tracing

     -Brian


    Azius Developer Training www.azius.com Windows device driver, internals, security, & forensics training and consulting. Blog at www.azius.com/blog

    Wednesday, March 29, 2017 7:01 PM
    Moderator
  • Well it looks like Mr. Russinovich is too busy and won't fix the pass-through. 

    I haven't looked at it for a while , IIRC once  there were a couple of alternative viewers that could address this issue.

    -- pa

    Wednesday, March 29, 2017 8:56 PM