locked
maxReceivedMessageSize & maxArrayLength size not taking....... RRS feed

  • Question

  • Hi, can someone help me to understand why the increased values for xxx and xx are not taking affect please?

    I am hosting my services in IIS 7.0 and they are running in Partial trust mode.

    My config extract:-

    <bindings>
            <wsHttpBinding>
               <binding name="Binding1" maxBufferPoolSize="2147483647" maxReceivedMessageSize="2147483647">
                   <readerQuotas maxDepth="2147483647" maxArrayLength="2147483647"
                      maxBytesPerRead="2147483647" maxNameTableCharCount="2147483647" />
               </binding>
            </wsHttpBinding>
        </bindings>
        
    		<services>
      <service behaviorConfiguration="ServiceBehavior" name="TEWSS.CMS.DATA.DirectoryDetailsbyParent">
      <endpoint address="" binding="wsHttpBinding" name="c" bindingNamespace="TEWSS.CMS.DATA"
       contract="TEWSS.CMS.DATA.IDirectoryDetailsbyParent" />
      <endpoint address="mex" binding="mexHttpBinding" bindingNamespace="TEWSS.CMS.DATA"
       contract="IMetadataExchange" />
      <host>
       <baseAddresses>
       <add baseAddress="http://tewss-001/TEWSS-CMS/" />
       </baseAddresses>
      </host>
      </service>
      <service behaviorConfiguration="ServiceBehavior" name="TEWSS.CMS.DATA.DirectoryContentsLight">
      <endpoint address="" binding="wsHttpBinding" name="WsHttpEndpoint"
       bindingNamespace="TEWSS.CMS.DATA" contract="TEWSS.CMS.DATA.IDirectoryContentsLight" />
      <endpoint address="mex" binding="mexHttpBinding" bindingNamespace="TEWSS.CMS.DATA"
       contract="IMetadataExchange" />
      <host>
       <baseAddresses>
       <add baseAddress="http://tewss-001/TEWSS-CMS/" />
       </baseAddresses>
      </host>
      </service>
      <service behaviorConfiguration="ServiceBehavior" name="TEWSS.CMS.DATA.DocumentDetails">
      <endpoint address="" binding="wsHttpBinding" bindingConfiguration="Binding1"
       name="WsHttpEndpoint" bindingName="Binding1" bindingNamespace="TEWSS.CMS.DATA"
       contract="TEWSS.CMS.DATA.IDocumentDetails" />
      <endpoint address="mex" binding="mexHttpBinding" bindingNamespace="TEWSS.CMS.DATA"
       contract="IMetadataExchange" />
      <host>
       <baseAddresses>
       <add baseAddress="http://tewss-001/TEWSS-CMS/" />
       </baseAddresses>
      </host>
      </service>

    I have tried pretty much everything I have read to resolve this an hence why I'm posting it again.....

    Many thanks,

    Tim 


    Behaviour Manager V4
    Tuesday, May 4, 2010 6:14 PM

Answers

  • Did you set these values at the client side also ?, if not then set those values at the client config then try
    Please mark as answer, if it solves your problem or Vote as helpful if you find helpful
    • Marked as answer by Tim Windsor Tuesday, May 4, 2010 7:50 PM
    Tuesday, May 4, 2010 6:43 PM