none
.NET Framework 4.0 Setup on Win7 sp1 x86 won't start the instalation RRS feed

  • Question

  • I have tryed deleting my  %temp% folder it didn't work. I Have also used the Collect tool, and cleaning tool ( to delete all the failed instalations and other versions of .NET Framework on my computer. Nothing did work. Please help me, I need this app for work.

    Here is my log:

    [11/11/2016, 23:46:9] === Logging started: 2016/11/11 23:46:09 ===
    [11/11/2016, 23:46:9] Executable: C:\Users\Ivan\Downloads\dotNetFx40_Client_setup.exe v4.0.30319.1
    [11/11/2016, 23:46:9] --- logging level: standard ---
    [11/11/2016, 23:46:9] Successfully bound to the ClusApi.dll
    [11/11/2016, 23:46:9] Error 0x80070424: Failed to open the current cluster
    [11/11/2016, 23:46:9] Cluster drive map: ''
    [11/11/2016, 23:46:9] Considering drive: 'C:\'...
    [11/11/2016, 23:46:9] Considering drive: 'D:\'...
    [11/11/2016, 23:46:10] Considering drive: 'F:\'...
    [11/11/2016, 23:46:10] Drive 'F:\' is rejected because of the unknown or unsuitable drive type
    [11/11/2016, 23:46:10] Considering drive: 'H:\'...
    [11/11/2016, 23:46:10] Drive 'H:\' is rejected because of the unknown or unsuitable drive type
    [11/11/2016, 23:46:10] Drive 'D:\' has been selected as the largest fixed drive
    [11/11/2016, 23:46:10] Directory 'D:\05443f57b3f7e1172ea511a794a6\' has been selected for file extraction
    [11/11/2016, 23:46:10] Extracting files to: D:\05443f57b3f7e1172ea511a794a6\
    [11/11/2016, 23:46:12] Extraction took 1.810 seconds
    [11/11/2016, 23:46:12] Executing command line: 'D:\05443f57b3f7e1172ea511a794a6\\Setup.exe   /x86 /x64 /ia64 /web'
    [11/11/2016, 23:57:49] Exiting with result code: 0x0
    [11/11/2016, 23:57:49] === Logging stopped: 2016/11/11 23:57:49 ===

    Friday, November 11, 2016 11:59 PM

All replies

  • Hi vaniborski,

    Welcome to MSDN forum.

    >>.NET Framework 4.0 Setup on Win7 sp1 x86 won't start the instalation

    >>Error 0x80070424: Failed to open the current cluster

    Do you mean that you couldn’t start the installer of .NET Framework 4?

    Error 0x80070424 translates to "The specified service does not exist as an installed service." I recommend that you should check whether or not windows installer’s service was started.

    Please refer to here to start the Windows Installer Service.

    After this, Download a fresh copy of the standalone installer for .NET Framework 4.0:

    http://www.microsoft.com/download/en/details.aspx?displaylang=en&id=17718

    Also, disable your AV software and sign on to your system with the Administrator user account you will use to run the installer, run the standalone installer as Administrator.

    If this issue persists, I need your help to collect the latest installation log. Please use http://aka.ms/vscollect to gather the installation logs. After using it, you will find vslogs.zip under %temp% folder. Please upload the file to https://onedrive.live.com/ and share the link here.

    Best regards,

    Joyce


    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Monday, November 14, 2016 3:28 AM