none
No symbols for ntoskrnl.exe on Microsoft's symbol server (KB2882822). RRS feed

  • Question

  • The ntoskrnl.exe (GDR branch) from Windows6.1-KB2882822-x64 update does not have public symbols. Where I can report this?

    symchk /v /if ntoskrnl.exe /s SRV*E:\SymbolsStore*http://msdl.microsoft.com/download/symbols

    Output:

    [SYMCHK] Searching for symbols to C:\Windows\winsxs\amd64_microsoft-windows-os-kernel_31bf3856ad364e35_6.1.7601.18247_none_ca38dbafcad85ead\ntoskrnl.exe in path SRV*E:\SymbolsStore*http://msdl.microsoft.com/download/symbols
    DBGHELP: Symbol Search Path: SRV*E:\SymbolsStore*http://msdl.microsoft.com/download/symbols
    DBGHELP: No header for C:\Windows\winsxs\amd64_microsoft-windows-os-kernel_31bf3856ad364e35_6.1.7601.18247_none_ca38dbafcad85ead\ntoskrnl.exe.  Searching for image on disk
    DBGHELP: C:\Windows\winsxs\amd64_microsoft-windows-os-kernel_31bf3856ad364e35_6.1.7601.18247_none_ca38dbafcad85ead\ntoskrnl.exe - OK
    SYMSRV:  E:\SymbolsStore\nt\ntkrnlmp.pdb\F69D000687EC491E87FC0425D4D378AC2\ntkrnlmp.pdb not found
    SYMSRV:  http://msdl.microsoft.com/download/symbols/ntkrnlmp.pdb/F69D000687EC491E87FC0425D4D378AC2/ntkrnlmp.pdb not found
    DBGHELP: ntoskrnl - no symbols loaded
    [SYMCHK] MODULE64 Info ----------------------
    [SYMCHK] Struct size: 1680 bytes
    [SYMCHK] Base: 0x40000000
    [SYMCHK] Image size: 6180864 bytes
    [SYMCHK] Date: 0x521ea035
    [SYMCHK] Checksum: 0x0054cbb3
    [SYMCHK] NumSyms: 0
    [SYMCHK] SymType: SymNone
    [SYMCHK] ModName: ntoskrnl
    [SYMCHK] ImageName: C:\Windows\winsxs\amd64_microsoft-windows-os-kernel_31bf3856ad364e35_6.1.7601.18247_none_ca38dbafcad85ead\ntoskrnl.exe
    [SYMCHK] LoadedImage: C:\Windows\winsxs\amd64_microsoft-windows-os-kernel_31bf3856ad364e35_6.1.7601.18247_none_ca38dbafcad85ead\ntoskrnl.exe
    [SYMCHK] PDB: ""
    [SYMCHK] CV: RSDS
    [SYMCHK] CV DWORD: 0x53445352
    [SYMCHK] CV Data:  ntkrnlmp.pdb
    [SYMCHK] PDB Sig:  0
    [SYMCHK] PDB7 Sig: {F69D0006-87EC-491E-87FC-0425D4D378AC}
    [SYMCHK] Age: 2
    [SYMCHK] PDB Matched:  TRUE
    [SYMCHK] DBG Matched:  TRUE
    [SYMCHK] Line nubmers: FALSE
    [SYMCHK] Global syms:  FALSE
    [SYMCHK] Type Info:    FALSE
    [SYMCHK] ------------------------------------
    SymbolCheckVersion  0x00000002
    Result              0x00010001
    DbgFilename         ntoskrnl.dbg
    DbgTimeDateStamp    0x00000000
    DbgSizeOfImage      0x00000000
    DbgChecksum         0x00000000
    PdbFilename         ntkrnlmp.pdb
    PdbSignature        {F69D0006-87EC-491E-87FC-0425D4D378AC}
    PdbDbiAge           0x00000002
    [SYMCHK] [ 0x00000000 - 0x00010001 ] Checked "C:\Windows\winsxs\amd64_microsoft-windows-os-kernel_31bf3856ad364e35_6.1.7601.18247_none_ca38dbafcad85ead\ntoskrnl.exe"
    

    Wednesday, October 9, 2013 11:41 AM

Answers

All replies

  • Hello andriy.c,
    I get exactly same error:

    SYMSRV:  c:\system\symbols\web\ntkrnlmp.pdb\F69D000687EC491E87FC0425D4D378AC2\ntkrnlmp.pdb not found
    SYMSRV:  http://msdl.microsoft.com/download/symbols/ntkrnlmp.pdb/F69D000687EC491E87FC0425D4D378AC2/ntkrnlmp.pdb not found
    DBGHELP: ntkrnlmp.pdb - file not found
    *** ERROR: Symbol file could not be found.  Defaulted to export symbols for ntkrnlmp.exe - 
    DBGHELP: nt - export symbols

    Could anyone give us an answer ?

    Bye,
    Luca


    Disclaimer: This posting is provided AS IS with no warranties or guarantees, and confers no rights. | Whenever you see a helpful reply, click on Vote As Help and click on Mark As Answer if a post answers your question.


    • Edited by Luca Fabbri Thursday, October 10, 2013 3:11 PM
    Thursday, October 10, 2013 3:09 PM
  • Hi everyone,

    I have the same the problem. I tried everything, even installed the symbols locally for Win7 SP1, but the signature is different.

    Any news from Microsoft?

    Cheers,

    Francisco

    Friday, October 11, 2013 3:11 PM
  • Try email to sysdev AT microsoft.

    According to their response - they are not responsible for those files.
    Tuesday, October 15, 2013 4:20 AM
  • Hi everyone,

    I might have a fix for it.

    I am using LiveKD (sysinternals), which is where I was unable to get the pdb.

    What I did was: in Process Explorer (sysinternals) went to (View -> System Information) and selected the memory tab.

    The required pdb for the ntoskrnl.exe was immediately downloaded. I even removed the installed symbols and tried again and everything works fine.

    Hope this can help you.

    Cheers,

    Francisco


    • Edited by FLRocha Wednesday, October 16, 2013 3:40 PM
    Wednesday, October 16, 2013 3:02 PM
  • I got response from windbgfb team - they fixed this issue.
    • Marked as answer by andriy.c Wednesday, October 16, 2013 11:12 PM
    Wednesday, October 16, 2013 11:12 PM
  • I got response from windbgfb team - they fixed this issue.

    How did you get in contact with the windbgfb team?

    This is (still/once again?) an issue with latest version of Windows 10 x64.

    Thursday, December 13, 2018 11:12 AM
  • Same issue in latest windows 10 x64 1809 build; looks like they gave up on the development side of windows drivers


    • Edited by tutudids Thursday, March 14, 2019 2:18 AM
    Thursday, March 14, 2019 2:17 AM