locked
Lightswitch desktop app will not launch on customer machines RRS feed

  • Question

  • I created lightswitch applications for two clients.  They are deployed as desktop apps with forms authentication.  They have been running for several months.  Yesterday I made a small change to both apps and redeployed them to the customer.  Neither will launch as I get a vslshost.exe will not launch and a HTTP Error 401 - Unauthorized error with a GetAuthenticationInfo query error.  I have read numerous posts and have installed fiddler.  The fiddler diagnostics after the HTTP Error 401 gives

    System.Net.Sockets.SocketException No connection could be made because the target machine actively refused it 127.0.0.1:52465 .  

    I can't figure out what has happened to prevent both customers from being able to launch the app and the yare getting restless. Hopefully someone can shed some additional light on the subject.  Thanks in advance for any assistance.                                                                                                                                                                                                                                                                                             


    Vern Miller

    Wednesday, April 23, 2014 2:01 PM

Answers

  • Thanks for replying.   After hours of searching and frustration I found a thread stating:

    The problem was that the Lightswitch application was deploying with Microsoft.Data.Services 5.0.2.0, but Microsoft.LightSwitch.Server 11.0.0.0 must reference Microsoft.Data.Services 5.0.0.0. Once I deployed 5.0.0.0 to the web server, the application ran as expected.

    That did the trick.  Thanks for everyone's time and help.


    Vern Miller

    • Marked as answer by VernMiller Monday, May 5, 2014 4:16 PM
    Monday, May 5, 2014 4:16 PM

All replies

  • I don't know if this will help any but the initial error detail is:

    Problem signature:


      Problem Event Name: CLR20r3

      Problem Signature 01: vslshost.exe

      Problem Signature 02: 11.0.50727.1

      Problem Signature 03: 5011cb66

      Problem Signature 04: mscorlib

      Problem Signature 05: 4.0.30319.18449

      Problem Signature 06: 528fdb6a

      Problem Signature 07: 26ac

      Problem Signature 08: e

      Problem Signature 09: System.IO.FileLoadException

      OS Version: 6.2.9200.2.0.0.400.8

      Locale ID: 1033

      Additional Information 1: 5861

      Additional Information 2: 5861822e1919d7c014bbb064c64908b2

      Additional Information 3: 1a2a

      Additional Information 4: 1a2aa8e38ac8adbb6fe1e594fa623c2e


    Vern Miller

    Wednesday, April 23, 2014 3:36 PM
  • Hi. Have you tried to uninstall their apps on there machines and reinstall. Second, clean their roaming folder under the user, reinstall. Third, does the app run on a IIs server hosted by the customer? Made any changes there?

    Sven Elm

    Thursday, April 24, 2014 4:38 AM
  • Good morning.  Yes I have removed the application and reinstalled.  I'm not sure what you mean by clean the roaming folder.  The database resides on the customer server 2012 server and uses sql server 2012. The other customer is setup the same but with server 2008 r2 and sql server 2008. I developed the app on my machine connected to the customer vpn and then published the app to my machine and moved the publish folder to a share on the customers server.    This technique worked fine for numerous updates. I guess the only thing that comes to mind is that the visual studio updates that have been applied over the last few months caused this.  I'm sure pulling my hair out.  Thanks so much for responding.

    Vern Miller

    Thursday, April 24, 2014 1:47 PM
  • Hi Remove the entire application on the remote server (iis) an redeploy. It will work. I promisse. After updates from 2012 to 2013 you cannot update, you have to remove the app from servers, not the database though and redeploy.

    Sven Elm

    Saturday, April 26, 2014 3:30 PM
  • Thanks again.  It was deployed as a desktop app.  I redeployed it using iis as you suggested and it still will not run.  I will keep tinkering and thanks much.


    Vern Miller

    Sunday, April 27, 2014 1:53 PM
  • I redeployed the application as a desktop app served by the customer IIS Server.  I totally removed the application and install folder on the customer machine and now I'm getting:

    Description:

    HTTP 404. The resource you are looking for (or one of its dependencies) could have been removed, had its name changed, or is temporarily unavailable. Please review the following URL and make sure that it is spelled correctly.

    Any ideas? Thanks.


    Vern Miller

    Monday, April 28, 2014 3:34 PM
  • Hi, You have to clear the Silverlight folder. Then it will work: Users\username\AppData\local\Microsoft\Silverlight\OutOfBrowser\ Delete your appfolder inside the \OutOfBrowser Do not delete the OutOfBrowser :) Regards Sven

    Sven Elm

    Monday, April 28, 2014 3:45 PM
  • Thanks. Unfortunately I got the same result but will experiment more when I return later this week.  Thanks for your help, I really appreciate it.

    Vern Miller

    Monday, April 28, 2014 4:01 PM
  • I think you refers to wrong path to your app. Try to run your app from your IIS and see what happens. If you have upgraded from a earlier version of LS you maby noticed that the OOB app uses a extra path like /client The path should then be: https://server/appname/client



    • Edited by Sven Elm Monday, April 28, 2014 4:11 PM
    Monday, April 28, 2014 4:11 PM
  • Thanks again Sven.  I'm out of town with no access to this customer until Friday.  I haven't changed the other customer over to IIS.  They are still a desktop app running on the users local machine from a publish share on the server.  I don't see a Silverlight share for these users.  I can certainly convert the other site to IIS when I return but curious if you had any ideas on this customer? Thanks.

    Vern Miller

    Wednesday, April 30, 2014 2:53 PM
  • Hello again.  I'm back and am struggling understanding how the IIS version runs from IIS itself.  When I try and run the application from IIS it gives me the option to sign in and provide a password but gives a 401 unauthorized error.  The path appears to be C:\inetpub\wwwroot\JeffersonCountyLegacy\Client


    Vern Miller

    Thursday, May 1, 2014 11:54 PM
  • What version do you run? VS2013 or 2013? Have you or the customer made any changes before you uoloaded a new version. Have you checked the server firewall?

    Sven Elm

    Friday, May 2, 2014 5:30 AM
  • Good morning. I'm using VS 2012.  As I earlier said I originally deployed the application as a desktop app running on the customers PC and not using IIS. I published the application to my development machine and uploaded it to the customers server on a share. I redeployed it many times without a hitch.  One customer had no updates whatsoever and I even turned the firewall off with the same results.  I have to think the only thing that could've happened was a couple of Microsoft updates to visual studio that broke the app.  It seems as if I'm getting a little farther using IIS on one customer machine but still no solution.  Thanks again for your time.

    Vern Miller

    Friday, May 2, 2014 2:20 PM
  • What operating system are the customers using?  Can you have them send you screenshots of the Windows Features that they have installed on their machines? (so we can check .NET framework versions installed)

    Did you add any new dependencies to the application (i.e. reference new DLLs) that are possibly not getting packaged?


    David Kidder | Senior SDET | Microsoft | LightSwitch

    Monday, May 5, 2014 4:07 PM
    Moderator
  • Thanks for replying.   After hours of searching and frustration I found a thread stating:

    The problem was that the Lightswitch application was deploying with Microsoft.Data.Services 5.0.2.0, but Microsoft.LightSwitch.Server 11.0.0.0 must reference Microsoft.Data.Services 5.0.0.0. Once I deployed 5.0.0.0 to the web server, the application ran as expected.

    That did the trick.  Thanks for everyone's time and help.


    Vern Miller

    • Marked as answer by VernMiller Monday, May 5, 2014 4:16 PM
    Monday, May 5, 2014 4:16 PM
  • Glad you were able to diagnose the problem.  Sorry that it took so long to do so.

    David Kidder | Senior SDET | Microsoft | LightSwitch

    Monday, May 5, 2014 4:33 PM
    Moderator
  • (A follow up question from this thread was split into a new thread)

    http://social.msdn.microsoft.com/Forums/en-US/lightswitch/thread/c2291b93-e44f-4f61-bf7b-66ed40e70608/#7ca536e6-287c-4fec-b38c-a5e1f6af29be


    David Kidder | Senior SDET | Microsoft | LightSwitch


    Tuesday, May 6, 2014 4:11 PM
    Moderator