locked
Report definition invalid target namespace 'http://schemas.microsoft.com/sqlserver/reporting/2008/01/reportdefinition' which cannot be upgraded. RRS feed

  • Question

  • User-498848506 posted

    Using VS 2010 Attempting to create a report using MSAccess 2010 database as the datasource.
    This error displays upon attmepting to run the report.

    If this makes any difference:
    The database ("Inventory.acccdb") is in the App_Data folder, and the report ("BarCodeReprt.rdlc") is in the App_Code folder.

    Other than that I cannot understand how this is to work.

    Thank you!

    Monday, June 3, 2013 2:16 PM

Answers

All replies

  • User-1528094326 posted

    Indicates a problem with the ReportViewer being loaded in your project. Have a look at the following post, and make sure your information lines up. Also check your web.config and make sure the correct assembly is being used. You want version 10 at least, not version 8

    http://social.msdn.microsoft.com/Forums/en-US/vsreportcontrols/thread/47ecd315-6372-46cf-b319-df098334fc74/

    Monday, June 3, 2013 7:36 PM
  • User-498848506 posted

    Thank you for responding.

    I had previously found that reference and tried all steps described.

    1. I downloaded and installed Report Viewer 2010
    2. To the  web.config file added the assembly reference:
      <add assembly="Microsoft.ReportViewer.Common, Version=10.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A"/>
    3. Verified "Microsoft.ReportingServices" file. The contents were already exactly as stated by Mr. Lafler

    Continue to get the same error. I am not even sure where the file in error is located?

    Thanks for any additional assistance.


     

    Tuesday, June 4, 2013 8:17 AM
  • User-1528094326 posted

    Which version of .NET are you targetting?

    Tuesday, June 4, 2013 6:43 PM
  • User260886948 posted

    Hi,

    The following article tells the details about how to solve this problem: http://quysnhat.wordpress.com/2012/07/05/error-the-report-definition-has-an-invalid-target-namespace-httpschemas-microsoft-comsqlserverreporting200801reportdefinition-which-cannot-be-upgraded-when-run-ms-reportvie/ .

    Turns out the issue was my "C:\Program Files (x86)\MSBuild\Microsoft\VisualStudio\v10.0\ReportingServices\Microsoft.ReportingServices.targets"  file had somehow changed.  The top of my file was:

    <Project xmlns="http://schemas.microsoft.com/developer/msbuild/2003">
    <UsingTask TaskName="Microsoft.Reporting.RdlCompile" AssemblyName="Microsoft.ReportViewer.Common, Version=9.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a"/>

     And it should have been:
    <Project xmlns="http://schemas.microsoft.com/developer/msbuild/2003">
    <UsingTask TaskName="Microsoft.Reporting.RdlCompile" AssemblyName="Microsoft.ReportViewer.WebForms, Version=10.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a"/>

    Or

    Please just install Microsoft Report Viewer 2010 SP1. You can go to this link to download then install MS Report Viewer 2010 SP1 .

    Hope it can help you.

    Best Regards,
    Amy Peng 

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Tuesday, June 4, 2013 10:17 PM
  • User-498848506 posted

    Thank you all...

    After spending way too much time looking into all suggestions and remedies, yesterday I finally found and downloaded MS Report Viewer 2010. Seems to be working now!

    Thanks again.

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Wednesday, June 5, 2013 7:22 AM