locked
Error adding account RRS feed

  • Question

  • User234320 posted

    I've been struggling with this for a while now trying to add my Apple Developer account to Xamarin Studio on Mac by using fastlane.

    No matter what I do I always get this:

    I've been generating multiple app-specific passwords and used those accordingly, but still get the same error. I have used app-specific passwords before without any problems, but in Xamarin Studio it keeps giving me headache with this repeating error.

    Does anyone have a solution to this?

    Thanks.

    Tuesday, April 4, 2017 11:30 AM

Answers

  • User234320 posted

    I fixed it, for anyone with similar situation try this:

    I switched to the latest version of Visual Studio preview on Mac, alpha-channel, and it worked. It even has support for two-factor authentication.

    • Marked as answer by Anonymous Thursday, June 3, 2021 12:00 AM
    Friday, April 7, 2017 9:55 AM

All replies

  • User1891 posted

    I had the same problem as you. Switching off Two Factor Authentication for my Apple ID solved the problem. Now I'm going to try and turn it back on...

    Friday, April 7, 2017 7:48 AM
  • User234320 posted

    I fixed it, for anyone with similar situation try this:

    I switched to the latest version of Visual Studio preview on Mac, alpha-channel, and it worked. It even has support for two-factor authentication.

    • Marked as answer by Anonymous Thursday, June 3, 2021 12:00 AM
    Friday, April 7, 2017 9:55 AM