none
Routes API: dateTime is ignored when routeAttributes is set to routeSummariesOnly

    Question

  • Hello,

    When route info is requested with routeAttributes=routeSummariesOnly, the server seems to be ignoring the dateTime parameter:

    Method: GET, RequestUri: 'http://dev.virtualearth.net/REST/v1/Routes/Driving?dateTime=01%2F10%2F2019+21:06:16&optimize=timeWithTraffic&routeAttributes=routeSummariesOnly&wp.1=Seattle%2C+WA&wp.2=Bellevue%2C+WA&key=***''

    "travelDurationTraffic": 912

    Method: GET, RequestUri: 'http://dev.virtualearth.net/REST/v1/Routes/Driving?dateTime=01%2F10%2F2019+22:06:16&optimize=timeWithTraffic&routeAttributes=routeSummariesOnly&wp.1=Seattle%2C+WA&wp.2=Bellevue%2C+WA&key=***''
    "travelDurationTraffic": 912

    However, if routeAttributes is e.g. not set, the dateTime is honored:


    Method: GET, RequestUri: 'http://dev.virtualearth.net/REST/v1/Routes/Driving?dateTime=01%2F10%2F2019+21:05:31&optimize=timeWithTraffic&wp.1=Seattle%2C+WA&wp.2=Bellevue%2C+WA&key=***''
    "travelDurationTraffic": 1077

    Method: GET, RequestUri: 'http://dev.virtualearth.net/REST/v1/Routes/Driving?dateTime=01%2F10%2F2019+22:05:31&optimize=timeWithTraffic&wp.1=Seattle%2C+WA&wp.2=Bellevue%2C+WA&key=***''
    "travelDurationTraffic": 1116

    Is it a defect or have I misunderstood the docs?

    Thanks,

    Serhii


    Friday, January 11, 2019 4:14 AM

All replies

  • Hi Serhil,

    I have passed a link to this post to the routing team for review.  They work on an agile cadence so I can not commit to a time to response.

    Sincerely,

    IoTGirl

    Friday, January 18, 2019 7:09 PM
    Owner