locked
VSTS Load test issue RRS feed

  • Question

  • Hi,

    I was trying to run a load test using remote controller and configured a database to store all the results, However after i start load test error is shown as below. Can some one guide me here?

    Error LoadTest2 c:\*****\loadtest2.loadtest The load test results database could not be opened.  Check that the load test results database specified by the connect string for your test controller (or local machine) specifies a database that contains the load test schema and that is currently available.  For more information, see the Visual Studio help topic 'About the Load Test Results Store'.   The connection error was: A connection was successfully established with the server, but then an error occurred during the login process. (provider: SSL Provider, error: 0 - The client and server cannot communicate, because they do not possess a common algorithm.)

    Wednesday, March 22, 2017 1:57 PM

All replies

  • Hi,

    I'm moving it to the dedicated VSTS forum, there you should get more professional responses.

    The reason why we recommend posting appropriately is you will get the most qualified pool of respondents, and other partners who read the forums regularly can either share their knowledge or learn from your interaction with us.

    Thank you for your understanding.

    Regards,

    Ethan Hua


    Please remember to mark the replies as answers if they helped.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, March 23, 2017 5:37 AM
  • Hi venkyb,

    >> I was trying to run a load test using remote controller and configured a database to store all the results

    Are you using the remote controller and database on the same computer?

    If remote controller and database not on the same computer, it could be caused by SSL algorithm parameters.

    Please check all the SSL and find the difference in database and remote controller. To check these parameters, go to registry (type “regedit” in Run command window)

    Check all the values underneath this key: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL.

    Changed the different between database and remote controller, make them consistent.

    SCHANNEL is Microsoft implementation of SSL.

    In addition, please enable SSL and TLS via Internet Options:

    Hope it help you!

    Best Regards,

    Oscar


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Thursday, March 23, 2017 9:37 AM
  • Hi,

    I am still facing this connectivity issue. Does Microsoft have any support in resolving these type of issues?

    Thanks,

    Venkat

    Tuesday, March 28, 2017 10:02 AM
  • Hi,

    I have 6 machines in total. Following was my complete setup to run load test. 

    Machine1  has controller. Machine2-4 has agent, Machine5 has SQL Server 2014 installed. This i used for storing database results. Machine 6 have completed vsts enterprise for preparing scripts etc.. 

    Versions:

    VSTS Enterprise 2015(which i used for scripting)

    Controller & Agents - visual studio 2013 update5

    SQL Server to store results- SQL Server 2014

    Now that my scripts were ready and want to run load test which is where i stucked up and unable to proceed further. Please suggest. I tried checking the above given suggesstion but that did not work.

    Thanks,

    Venkat

    • Edited by venkyb Tuesday, March 28, 2017 10:20 AM
    Tuesday, March 28, 2017 10:19 AM
  • Hi Veky

    Please see this Thread 

    Cheers

    Wednesday, March 29, 2017 1:41 PM