locked
InfoPath Form Read-Only without Gray Text RRS feed

  • Question

  • Hello,

    We are currently using a Forms Library in SharePoint.  We have two different forms in the Forms Library.  Each form has an Edit and Read-Only view.  In the Read-Only view, all of the text is grayed out.  There are many rich text fields in the forms that people use to highlight important information in different colors.  When the text is grayed out it becomes easy for people reading the form to miss important information.  Is there any way to make a view Read-Only without the gray text? 

    Thanks,

    Amy

    Monday, September 17, 2012 3:50 PM

Answers

  • You can create a regular view and use Calculated Fields to display information instead of Read-Only controls. This way you can format the fields however you want.


    Manaz Mohideen - MCPD, MCITP, MCTS

    • Proposed as answer by Jason Li - Canada Tuesday, September 18, 2012 5:41 AM
    • Marked as answer by Entan Ming Thursday, September 27, 2012 6:47 AM
    Monday, September 17, 2012 6:30 PM

All replies

  • You can create a regular view and use Calculated Fields to display information instead of Read-Only controls. This way you can format the fields however you want.


    Manaz Mohideen - MCPD, MCITP, MCTS

    • Proposed as answer by Jason Li - Canada Tuesday, September 18, 2012 5:41 AM
    • Marked as answer by Entan Ming Thursday, September 27, 2012 6:47 AM
    Monday, September 17, 2012 6:30 PM
  • Thank you for the response Manaz.  I will give that a try.

    Amy

    Thursday, September 20, 2012 3:26 PM
  • This option doesn't work for the Person or Group field. Can't use calculated columns to display that content. We have a form that displays the created by name in the printed name portion of a signature line and because it's a read only field it displays in very light grey text making it difficult to read for some users. Is there any way to darken this without having to do a lot of modification to the list?

    Thanks for any help anyone can give.

    Chris

    Wednesday, April 2, 2014 6:43 PM