locked
Debug Silverlight Application with IIS RRS feed

  • Question

  • Hi

    I have already developed a silverlight application and everything works fine.
    Now I want to add a Log-In to my project and took this tutorial:

    http://www.silverlightshow.net/video/WCF-RIA-Services-Webinar-3.aspx

    To debug the login i switched the settings of my .Web project to the local IIS webserver. Which also is working.
    But when start debugging my application from Visual Studio 2010 in my webbrowser always the absolut filepath is given instead of an url.

    And when I go to my IIS Management Console and choose "lookup webpage" I always get a blank page...

    Does anyone this problem?

    Thanks in advance

    Friday, March 21, 2014 2:59 PM

Answers

  • Hi Bazilinho,

    Your service reference points at the web site in the context of running under the VS Development Server. When you change it to IIS, it runs under a different context, and it could not run correctly if there is nothing change. I think you may need to update the service reference if possible.

    I think you may interested with this blog for cross domain debug: http://blogs.msdn.com/b/carlosfigueira/archive/2008/03/07/enabling-cross-domain-calls-for-silverlight-apps-on-self-hosted-web-services.aspx

    --James


    <THE CONTENT IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND, WHETHER EXPRESS OR IMPLIED>
    Thanks
    MSDN Community Support

    Please remember to "Mark as Answer" the responses that resolved your issue. It is a common way to recognize those who have helped you, and makes it easier for other visitors to find the resolution later.

    Monday, March 24, 2014 5:10 AM
    Moderator