locked
Remote Debugger Tool

    Question

  • I am running Windows 10 Build 10041 with Visual Studio 2015 CTP 6/Windows 10 SDK Developer Tools.  When I try and debug my app onto my Surface Pro 3 I have issue running remote.  Also, using Visual Studio Remote Debugger 2015

    If I try and run an older app within CTP 6 using Local Host it works fine.  If I try and do remote client, I get the following errors

    1>------ Deploy started: Project: DPS, Configuration: Release Any CPU ------
    1>Error: The method or operation is not implemented.
    ========== Deploy: 0 succeeded, 1 failed, 0 skipped =========

    I can see the the client trying to connect to SP3 and gets a "Failed attempt to connect" error.

    Now, Issue #2

    Created a new Windows 10 UA and tried to debug remote to SP3 and get the following error:

    1>------ Build started: Project: App2, Configuration: Debug Any CPU ------
    1>  App2 -> c:\users\xxxxxx\documents\visual studio 2015\Projects\App2\App2\bin\Debug\App2.exe
    2>------ Deploy started: Project: App2, Configuration: Debug Any CPU ------
    2>Error: The method or operation is not implemented.
    ========== Build: 1 succeeded, 0 failed, 0 up-to-date, 0 skipped ==========
    ========== Deploy: 0 succeeded, 1 failed, 0 skipped ==========


    • Edited by EBCAnger Thursday, March 26, 2015 10:40 PM
    Thursday, March 26, 2015 10:40 PM

Answers

  • Found the issue, it seems that the "Remote Debugging Monitor" on the download site is an older build.  Once you load the Windows 10 sdk, it seems that the RDM files get updated to  Version 14.0.22609.0 built by: D14REL to where the one that is currently loaded on the MS site is Version 14.0.22310.1 bult by:DP

    To get around the issue, I copied the files from my dev pc to my surfacepro 3 and everything worked fine.

    • Marked as answer by EBCAnger Sunday, March 29, 2015 12:04 AM
    Sunday, March 29, 2015 12:04 AM