External Western Digital HD not being recognized


  • I recently purchased a Western Digital 500 GB External HD. I had backed up a lot of my data and files onto it and did a fresh install of Vista home premium on my desktop. When I tried to connect the USB for the HD, Vista wouldnt recognize. I dont see any errors but Vista simply seems ti ignore the new device. To check if the USB ports are working I interchanged my other USB devices and Vista correctly recognizes them. I searched through Western Digital KB and didnt find anything helpful.
    I didnt want to call their tech support as they very conveniently mentioned they will charge me for it.
    Is anyone familiar or knows what I need to do to get this fixed?
    Monday, July 09, 2007 9:19 PM

All replies



    I can't do anything with my USB-ports!! (exept mouse)


    I can't use:

    • WD external hd (500 GB)
    • USB-stick (ALL types)


    is there a fix for this? I can't do anything usefull!
    Saturday, September 29, 2007 11:36 AM
  • What the hell with Vista Drivers !
    I have 2 laptop at the office (1 Acer and 1 Fujitsu) with Windows Vista Ultimate
    On the fujitsu, the WD Passport 160 and 250 work fine !
    But on the Acer, Vista do not even recognize these drives.
    5 years of development with no proper answer, what an amazing new tech OS !!!!
    If anyone has the answer ...
    Monday, October 08, 2007 10:32 AM
  • I have the same problems, I have a WD 250gb Media Center that worked great on an old laptop, I bought a new laptop(Vista) and a new WD "My Book Essential" 500gb external, plugged them both in to th new laptop, the 250gb works, the 500gb worked once or twice but now vista just ignores the 500gb drive, I have contacted WD and they have no clue, Micro-shaft doesn't seem to care much either. Does anyone have any suggestions other than swithing back to XP or going MAC?


    Friday, November 09, 2007 7:01 PM
  • I bought a 500MB USB WD drive 2 weeks ago and bought the new system w/Vista.  Same problem . . .just ignores it.  HELP!!


    Thursday, November 29, 2007 5:11 PM

    Thursday, November 29, 2007 5:11 PM
  • Hello,


    I have found a solution for this problem.


    I have a Acer laptop with Windows Vista. It didn't recognize a USB Microsoft keyboard and my new external WD harddisk of 500GB. It appairs that a file named infcache.1 was corrupt.


    You have to delete c:\windows\inf\infcache.1 with a administrator account (full access).

    When it's removed you can retry to plug in your USB-devices and the devices will work.






    Sunday, December 16, 2007 11:51 AM
  • Can you advise how to get full access?  My admin account isn't letting me delete the file.  I've read that you need to access the hidden admin account - any ideas?  The instructions I found were for a beta version of vista and I'm afraid to lock myself out of my computer.



    Sunday, December 16, 2007 11:30 PM
  • All you need to do to get full access is to click on the file click on the properties, then click on edit of your computer name from the list, (the one other then the system) click on edit and then a load of tick boxes should come up and click on full control and you then can delete the file. Ever since i deleted the file, my computer reconises everything, even my ipod!

    Wednesday, January 02, 2008 10:16 PM



    I know it is rather late in the day for this thread, but as I have just been battling to get my Passport 250 to be recognised, I thought I'd share a possible cure which worked for me.


    Simply use the SHORT WD supplied USB lead.


    I have a number of USB2 leads, including one bought today.

    It is only the original short one that worked.

    My Passport worked fine with a longer lead as well - but then for some reason the WD 250 GB Passport failed to connect again - despite working pefectly on 4 PC's including an old pentium 3 model.


    It seemed to have this happen after the last Windows XP update - but I honestly doubt if that's the reason.


    I know this is a bit simple, but it surprised me! So I hope this thread is of some help to someone else!








    WD 250 GB Passport failed to be recognised

    WD 250 GB Passport failed to be recognized

    WD Passport failed to be recognised

    Western digital Passport failed to start

    Cannot access Western digital Passport




    Wednesday, January 09, 2008 12:51 PM
  • lol yer this is absolutly true to begin with i was pissed bcoz wen i got this i had to bend down and go aroundf in a tiny gap behind ma desk to plug in ma wdpassport but then i found a long cable 4 ma mp3 then i used that , but after a while it stopped working on my account and i has the shits soooo bad then just today after reading these forums i realised that the only way to get then to work is bu using the short cable
    Monday, January 14, 2008 1:57 AM
  • Thanks Ann,

      This was exactly it.

    1. I used a longer USB2 cable and Vista did not recognize my WD250. Never payed attention to what cable I used. 

    2. I tried using the shorty usb cable that was supplied and it found it right away. 

    3. Tried using long cable into a 4 port USB device on XP. Not recogized

    4. Tried using long cable direct into laptop port on XP, did recognized.


    The short cable labels as high speed usb revision 2.0. Not on my long cable. Wonder if these revisions change the power supply consumption configuration that machines use.




    Wednesday, January 16, 2008 10:35 PM
  • This is straight from WD Website - I have tried it with no success. I have a 500 GB  My Book Premium.


      Why does Windows Vista fail to detect or install drivers for an external hard drive?
    During the initial installation of an external hard drive, Windows Vista does not locate or install drivers for the external hard drive. Windows Vista might report that there is “no driver found for you device” and/or will not display the pre-installed Vista OEM drivers. Even by manually selecting the driver, you will still get the “no driver found…” error.

    This is most likely caused by a corrupted INFCACHE.1 file. This file stores the location of drivers and their INF files. This file is hidden, has restricted access, and can be found in “c:\windows\inf”.

    Delete the INFCACHE.1 file and it will force Windows to rebuild the INFCACHE.1 file the next time Windows searches for drivers. To delete this file, you have to set the security permissions of it to allow Full Control for the User Group Administrators or full control for your user account. Please follow the directions below:

    1. Open a Windows Explorer window by right clicking on Start and then clicking on Explore.

    2. In the address bar, type C:\windows\inf and press Enter.

    3. Find and then right click on the file named INFCACHE.1.

    4. Select Properties.

    5. Click on the Security tab.

    6. Click on Edit to edit the permissions of the file.

    7. Click on Add to add User Groups.

    8. Type Administrators in the User Groups field and click on OK.

    9. Set Administrators to Full Control and click on OK.

    10. Move or delete the file INFCACHE.1.

    11. Reinstall a device to force Windows to rebuild the INFCACHE.1 file (DO NOT reinstall the same external hard drive that you were having issues detecting before. Please connect another USB device other than the one that Vista had an issue detecting).
    This detection issue can happen several times in a row, but repeat the steps 1-11 and try again until this works.


    Wednesday, January 23, 2008 1:50 AM
  • I have followed your directions to the tee at least a dozen times; I have used my phone, my ipod, a flash drive, and a usb mouse to rebuild the infcache.1.  No matter what I do I get the same thing everytime: Windows couldn't find driver software for your device.  Any help with this would be greatly appreciated.  My home computer has crashed twice before and then I bought this Acer laptop with Windows Vista and the WD My Book Essential Edition 2.0 to back everything up.  It says it's compatible with Vista and I would really like to not have to go through a complete week of getting everything back to normal after I have a system crash again.  Isn't there a way to just download the driver for WD My Book for Vista?

    Friday, February 22, 2008 3:11 PM
  • This should fix the issues you are having:


    1. Plug the HD into a pc that recognizes the drive and explore

    2. Copy and burn the following folders onto a CD (or thumb drive)

    a. WD_Windows_Tools

    b. autorun

    3. Insert the CD (or thumb drive) into your Acer and copy them to its desktop (or where ever you want)

    4. Double click the Setup.exe and WDSetup.exe and go through the on-screen steps

    5. Plug in your Western Digital HD


    I had very similar issues and all is well finally.

    Monday, March 03, 2008 2:23 AM
  • Hi


    in adition also if you desktop has a intel mainboard you can try to update the intel chipset driver for the latest version and and then perform the steps with the INF file againd.

    If you dont have a intel board you must use the latest chipset update from the manufacturer






    Tuesday, March 04, 2008 3:41 PM
  • Try a possible solution on http://jchenry.net/FAQ2.aspx


    Thursday, March 13, 2008 4:03 PM
  • I also had this problem, but solved it with a couple of hours of thrawling the web.
    I tried the INFCACHE solution. I tried the usb cable solution.

    Browse to your windows\inf directory and search for the file USBSTOR.inf
    My guess is that you don't have it or it is located in a different folder.
    Download it/move it into windows\inf and plug in your harddrive.
    Problem hopefully solved.

    • Proposed as answer by LordFlavius Sunday, February 07, 2010 11:23 PM
    Monday, March 24, 2008 9:08 PM
  • You are a lifesaver - thank you so much.


    Monday, March 31, 2008 8:47 PM
  • Im having the same problem with my WD 'my book' 320gb. on Vista SP1
    I have tried all solutions. inc deleting the infcache.1 file. checkin usbstor files. trying to update the driver manually, and every other solution on every other forum..

    This is REALLLLY p'in me off now. The HDD is shown in the bios start up, but vista will just not recognise it. It just puts it as an uknown device in device manager with no drivers installed. when trying to update drivers it says these are best drivers for the device.

    Every other USB device I have works flawlessly with Vista SP1, and the HDD works flawlessly on my other XP machines.

    I did get the HD to install once after 100's of different attempts but as soon as I restarted the computer it dissappeared and can't install it again. WD support say there HD's use generic microsoft drivers, and as the HDD is seen in the BIOS, and works fine on XP machines, my conclusion is this purely a Vista driver issue.

    HELP MICROSOFT! this has been an issue for WD HDD users for what looks like over a year so why hasn't this issue been solved?
    Monday, April 07, 2008 9:59 PM
  • This issue has now cost me nearly $2000 in lost productivity time.. If this is such a common problem, which by a quick 'GOOGLE' of 'USB hard drive not recognised by vista' clearly proves.... Why hasn't this issue been solved microsoft?
    Thursday, April 10, 2008 12:52 PM
  • Guys, before you try anything more complicated, which I did, I want to reiterate that you should try to use a very short cable to connect your Hardrive.  Whe I used a long cable, I heard Vista making connect/disconnect sounds.  I think the long cable is too long to communicte properly with the passport drive.  Keep in ming that it's pretty amazing that this drive even works without an external power.  I changed to a very short 3 inch usb cable and it began installing the software needed.  Try the short cable first.





    Sunday, May 04, 2008 3:30 PM
  • Guys,


    I also had the problem with the WD external drive: was working great until I rebooted today and windows stopped recognizing. I was really upset because I have everything there and after reading some of the stuff online I almost gave up. I saw this thread mentioning the INFCACHE.1 file and gave it a try. After rebooting and reconnecting my drive, voila! The drive is there as if it was never gone.



    Monday, June 02, 2008 4:54 AM
  • I am having the same problem with my Western digital 25G external drive. I have windows XP and just like you said when I re-booted my computer it failed to recognize the device. It shows up in my device manager in bold letters as Unrecognized device. It won't give me anymore information or allow me to use the device wizard to gather more information. I have tried switching ports as well and tried to update all of the drivers. Tomorrow I should get a reply from Windows live help and will call the guy who installed it for me at Toshiba. I have wasted an entire day and night trying to troubleshoot this problem. It's really frustrating isn't it!  I will let you know if I get more information about fixing the problem. 


    Tuesday, June 10, 2008 5:45 AM

    I had the same problem with my WD Dual-Option external HD. After connecting the USB plug to my PC, Vista device manager didn't even show up the newly connected device. No reaction - not even a refresh in device manager, wich usually indicates a device detection.

    I tried deleting the INF Cache, etc. without success. What actually helped in my case was disconnecting the USB drive from the power supply for a while. After reconnecing the power and USB plugs the device was detected immediatly.

    Really strange.

    Tuesday, June 10, 2008 9:45 PM


    Sometimes, similar problems might be caused by insufficient power supply.


    1. Plug the power cable (if any) of the external hard disc directly into the main socket. Unplug and try again.

    2. Plug the USB cable directly into the computer (do not use a hub, etc.)

    3. Check all USB ports (typically, some of them provide much power than the others).

    4. Try with another, shorter (shortest) USB cable.

    5. Try with a cable with three USB ends (one end - plugged into the external hard disc; the other two ends - plugged together, in the same time, in two different USB ports of the computer, providing in this way much power supply).


    Sorry for my english and wish you good luck!


    Saturday, June 14, 2008 12:52 PM
  • My experience is just as varied.


    Windows Vista Home 32bit, 1TB WD Mybook external Pro III.


    Installed the CD that came with it

    At first, it would not recognize the device (USB Device failed...replug or replace)

    Then, I tried the firewire...it recognized there was a device, but I couldn't do anything

    Then it stopped recognizing a device was there at all.

    Tried the USB again (I don't have a connection for that third cable...what is that? Firewire 800?)

    Deleted INFCache again and again, to no avail

    Now it recognized the Mybook, the ButtonManager program ran, but still nothing in the recognizing and using the HD

    Uninstalled all drivers

    Downloaded new drivers from WD website

    USB gave the same recognition, but still no use

    USB Device failed. Deleted INFCache. And again. Still nothing. Repeat this line over and over all night.

    Suddenly, now the device is not even detected. I thought I broke the HD permanently. Went to bed and powered down all electronics in the room. Even my cell phone is in another room. Thank goodness it's a weekend and I don't work tomorrow.

    Saturday, powered back up. Played some mind numbing video games. Time to try again.


    Switched back to firewire...Device manager showed the HD and no failures. Hmmmm...

    Went to Computer Management and what the? It's there and ready to go. I hate Vista.

    Tried to format the entire 1TB in one run. Immediate failure. I'm going bald.

    Partitioned into 2 equal drives. Tried to quick format one then the other. Immediate Failure.

    Tried to format using normal format (not Computer Management). Still failure.

    At least I can still see the HD, even if I can't write to it.

    After various partition variations, I'm back to 2 equal sized drives again

    Both drives show up and I'm full formatting both

    It's been nearly 24 hours of formatting and each are at 2% formatted. This is going to take forever. Is it supposed to take this long? It's the Fourth of July now, so I can't even call WD tech support to find out if this is normal to take this long to format.


    I guess technically, I'm not at success yet. I haven't successfully stored any information on the HDs, but it's going. Maybe someone can make sense of the sequence of events. I sure can't. Best I can tell, I got lucky. I also hope this can help someone else out there. I was super frustrated when I was doing it.


    Best of luck to everyone reading this!

    Friday, July 04, 2008 6:58 PM
  • Thanks for the 'shorter lead' idea.  Spot On!  It's the ONLY thing that worked (and I spent days and days trying everything else).  Cheers.

    Saturday, July 19, 2008 8:57 PM
  • Yes! Plugging the power cable directly into the main socket works perfect. After doing all the INFCACHE stuff mentioned in other threads.

    Thursday, August 14, 2008 6:30 PM
  • I'm on XP - will this work for XP?

    Friday, August 29, 2008 1:08 AM
  • Monolo:

      Yes it will and so work very well. However you need to set it up directly from your hub computer. Then after you have done that it will show you a black icon for western digital set-up.  Follow the directions for that and then just use a simple password like your first or middle name. It will take awhile to back up everything the first time but after that just plug it in just after signing ing anytime you want and you can just open it up from the littl plug and play icon with a green check mark in front of a radio type icon in your icon tray at the bottom of your windows screen. It takes awhile to open but it will then open and copy all of the things you have asked it to copy when you first set it up. My computer guy who is very good told me to just skip using with Microsoft One Care because it tends to copy and back up too many things that you may not really want or need.  This way you can choose from the beginnning of the set up which items you would like it to always back-up, then go back and delete it you want. Hope it works out for you. Let me know!  Sounds like it's a real problem for Vista users thought! 


    Saturday, August 30, 2008 10:54 PM
  • Thanks Ann for your solution!

    I spent hours deleting infcache.1 and copying usbstor.inf and rebooting, etc.

    Then I followed your solution of using the USB cable that shipped with the My Passport. It works fine now. Vista picked it up immediately and now I can use it.

    I had to dig my cable out of the trash, since I have USB cables all over the place....I didn't think I needed to keep another USB cable around....glad it wasn't trash day!


    Thursday, October 09, 2008 6:27 PM
  • I have the same problem with Windows XP. I guess that Western Digital just wants to gouge us for more money.

    Sunday, October 12, 2008 8:31 PM
  • Ann


    Your advice helped. I did use the short cable, but through a 4 Port USB 2.0 Hub. Once I plugged the WD directly into the USB port of the PC, it worked.



    Monday, October 13, 2008 6:36 PM
  • I guess thats the problem

    A very short cable came with my passport and a friend came visit with his dial up connection which uses the same cable but longer

    I swapped the cable when he wasn't looking
    Now i have to find a way to get my cable back.

    Following 4 posts by 4 different people here about using the cable that came with it. I guess i will try getting the cable back

    Although i am yet to get it back, something tells me it is the cable cos i already bought close to 15 cable now (thanks to the quest for getting WD to work, by fire by force, i mean, i cant let 2 months downloads go like that) and somehow, some cable work with some computers, others wont, even trying it to the umpteenth time, the same cable that works will always work, while other will always not work

    I will let you know if it works
    Monday, November 24, 2008 9:35 AM
  • I have the same problem but When I check Device Manager it shows that the device is installed and working properly but it will not show in "my computer" and I can't access it.


    Tuesday, November 25, 2008 6:59 PM
  • I have the My Book 1tb hd. I have tired EVERY method on this site and none of them work. I see my hd in the device manager. I go in to disk manager. I see the drive, but its not initialized. I right click and i get an error. I have so much info on this drive. i have only had this drive for 2 WEEKS. Can SOMEONE ANYONE HELP!?!?!?!?!
    Tuesday, December 23, 2008 11:14 PM
  • nothing worked with me infcatche.1 delete , usbstor.inf move from another pc , devise manager unistall the drive

    it work in the end

    this is how go to computer right click manage / storage / disk managment right click on the un named drive change latter & path /change & select the letter  finish

    the source http://www.fixya.com/support/t852028-pc_not_recognizing_wd_passport_120gb_usb

    Friday, July 03, 2009 10:40 AM
  • In my case, I tried every software download, but it didn't work...

    So, I tried changing the USB cable, just to cover the all ground... And IT WORKED!!!!

    Later,I found out that many of USB cables that comes with the Western Digital drives are faulty.... So try this...
    Wednesday, July 22, 2009 3:15 AM
  • Hi, When I go to Disk Management and right click, it only shows Refresh, Rescan Disk, View and help, but it does not allow me to change the letter. Any solution to this? thanks
    Sunday, March 28, 2010 10:46 PM





    • Proposed as answer by Paulv81 Friday, May 07, 2010 7:32 AM
    Friday, May 07, 2010 7:32 AM

    I tried everything told in this thread, and nothing worked. Not even the shortest cable possible.. UNTIL I plugged it straight to the motherboard - Everything works nicely! The external hd doesn't get enough power through the front panel usb ports because of the longer wiring. Sounds logical to me?


    Monday, August 02, 2010 2:47 PM
  • nothing worked with me infcatche.1 delete , usbstor.inf move from another pc , devise manager unistall the drive

    it work in the end

    this is how go to computer right click manage / storage / disk managment right click on the un named drive change latter & path /change & select the letter  finish

    the source http://www.fixya.com/support/t852028-pc_not_recognizing_wd_passport_120gb_usb


    Have been experiencing recognition issues with my WD Elements 120Gb portable for some weeks following a reinstall of Vista.

    The drive was showing in the Hardware as active with correct drivers etc etc, but failed to list in Explorer.

    Unsuccessfully tried several fixes as spoken about here, but right now after following the above instructions to a point where the drives were listed, I noticed that the drive was listed as "healthy" "Primary" but not "Active/Primary Partition" and blank where other drives were listed as NTFS.  (I did not see an option to "change letter & path").

    I deleted the partition and then was able to reformat as Active / NTFS together with the label/letter options.

    Pleased to say that now although whatever files I had on the drive are lost, the recognition is back.




    Wednesday, August 25, 2010 11:00 AM
  • I had this issue on Windows 7 using WD5000MT external drive. After I installed WD device manager from the WD site and formatted the drive using FAT32, the device became recognizable in My Computer.  Hope this helps.
    Tuesday, January 04, 2011 3:38 AM
  • This forum is for help in writing Windows-search aware software. Try answers.microsoft.com for help in using Windows.

    The following is signature, not part of post
    Please mark the post answered your question as the answer, and mark other helpful posts as helpful, so they will appear differently to other users who are visiting your thread for the same problem.
    Visual C++ MVP
    Tuesday, February 08, 2011 6:10 PM
  • I was having  that problem but on an Xp system.  What I noticed is when you go to disk management it shows the drive but no drive letter.  Just right click and assign a letter to the drive.
    Tuesday, March 29, 2011 7:21 AM
  • Just came across this as my Dad's passport seemed to stop working and wasn't initialised on Windows. What I have discovered may help some of you. We had put password protection on the drive using the backup/smartware software and I had completely forgotten. However, if you open the WD Smartware from the 'CD Drive' that appears when you plug in the hard drive, it will ask you for the password which once entered, then enables Windows to read and display the hard drive letter in My Computer. Just thought this may help some of you and those googlers that come across this in another year or two
    Saturday, April 09, 2011 3:59 AM