locked
Visual Studio 2010 does not load current files anymore RRS feed

  • Question

  • User1582969803 posted

    I have been using Visual Studio 2010 Express for quite sometime now. After closing with files opened (and saved) it would always remember the files and reload them upon a new startup. But today that doesn't happen anymore.

    I can't find an option that may need to be turned on again.

    Does anyone know where that option is?

    Wednesday, September 7, 2011 7:41 PM

All replies

  • User470413944 posted

    Hi,

    You can try to change your startup options by Tools -> Options -> Environment -> Startup -> At startup: Load last laod solution.

    I hope this can be helpful for you.

    Monday, September 12, 2011 10:40 PM
  • User1582969803 posted

    I have already made sure that is set. The solution does automatically load, the problem is that the open files do not re-open.

    I have found that if I change to Basic Settings then it works as expected but Basic Settings does not show External Tools and I need that.

    Wednesday, September 14, 2011 11:08 AM
  • User-1641312964 posted

    I had the same issue in VS 2010.

    I was able to fix it by resetting my settings.

    In VS 2010, go to Tools --> Import and Export Setting --> Select Reset all setting.

     

    Wednesday, June 27, 2012 5:25 PM
  • User888251099 posted

    This happened to me as well, but I didn't want to reset all my settings.  So here are a couple things to try before that:

    1. Export your settings (Tools -> Import and Export Settings) and open the resulting file in a text editor.  Search for a section starting with "<Category name="Environment_WindowLayout"".  In my file, there were two places with a riduculous amount of duplicate "<ViewBookmark" entries.  I deleted all but one in both places then I imported this file into VS and it fixed it for me.  Note: I re-imported everything.

    2. Along the same lines as above, I read a post about exporting your current settings and then importing the resulting file but excluding window layouts (All Settings -> General Settings -> Window Layouts).

    Friday, September 28, 2012 5:52 PM
  • User-1879712429 posted

    This is an old thread but now I'm facing the same problem with VS2013. I tried the solutions provided here but no luck, and I didn't expect they would work because the problem is all about project-wise settings not the overall environment.

    So I did some research and found the solution:

    1. There is a hidden file with extension .suo in the solution folder, you'll see it if you set hidden files visible by using Folder Options.

    2. Delete or rename this file.

    3. Restart VS, VS will create a new .suo file to store the solution/project settings.

    4. The next time you start VS, everything will be fine again.

    Monday, August 25, 2014 3:04 PM
  • User-1309596090 posted

    Thank you.

    Your solution works for me too! ;-)

    Wednesday, October 8, 2014 10:35 AM
  • User-2059499871 posted

    I had the same problem with Visual Studio 2013, and I also didn't want to reset all of my settings.  I solved it by doing this:
    - Export my current settings (Tools > Export and Import Settings), making sure to UNMARK General Settings > Window Layouts.
    - Re-import the settings I just exported, but making sure I left General Settings > Window Layouts MARKED now (so it would overwrite the current Window Layouts with the "clean slate" of the imported settings.

    Monday, May 11, 2015 7:27 PM
  • User-1423007643 posted

    I wasn't able to find the Window Layouts option when I was importing the old settings; however, I was able to simply use one of the default settings sets that was provided as an option for importing.

    Friday, August 7, 2015 8:45 AM
  • User-1128319161 posted

    It changed again in VS 2015.

    Now the .suo file is in a hidden folder.

    From the project solution folder\.vs\projectname\v14\.suo

    Delete or rename this file.

    Thursday, August 27, 2015 5:13 PM