none
Urgent: Word addin will not load! RRS feed

  • Question

  • Hi all,

    Last year I developed a VSTO-addin for Word 2007, using Visual Studio 2008. I generated a temporary certificate which I used to sign the application with, and then published it to a file server using Click Once.

    I have successfully made adjustments to my code and re-published over 100 versions since version 1.

    Now suddenly, last week, I made some very simple changes to my code and published a new version, which works great on my development machine. However I cannot by any means get the other client computers on our organization to successfully load the addin!

    I go to Options under the Office-button, and click the Addins-tab on the left pane, and then the COM-addins box on the right pane. I see that my Addin is in the list of addins, but it is unchecked. I check it, and hit OK, but it is not loaded. If I go in to the options dialog again, I see that it has become unchecked again :-(

    I have searched the internet for a solution to this problem, and tried various tips and tricks, but none of which have worked...

    I would be very, very grateful if anyone could please assist me on this matter, as it is quite important that I fix this really quickly now :-)

     

    Thanks!

     

     

    Monday, October 24, 2011 8:18 AM

All replies

  • Hello,

     

    Check the Disabled Items tab found in the same combobox where the "COM-addins" option is found. If the add-in is there means that your code generated an error while loading. Enable it and the go and check it again in the "COM-addins" section.

     

    Best regards,

    Silviu.


    http://www.rosoftlab.net/
    Monday, October 24, 2011 10:45 AM
  • Thank you for your reply!

     

    I already tried what you suggest, but every time i re-check the checkbox it gets automatically unchecked again :-(

     

     

    The translated message at the bottom says: "Not loaded. A runtime error occured while loading the COM-addin". It does however work on my dev-machine. Is there any way I can see the error message that the addin generated?

     

     

     

    Monday, October 24, 2011 10:52 AM
  • Hello,

     

    Does it appear in the Disabled Section (section appears when you select "Deaktiverte" from "Behandle" and then press Start)?

     

    Try in the constructor of the ribbon to add a try-catch and to messagebox.show(exception.message).

    Or if you have some code that loads then the add-in loads, add some try-catch there and MessaBox.Show(exception)

     

    Best regards,

    Silviu.


    http://www.rosoftlab.net/
    • Edited by Lupu Silviu Monday, October 24, 2011 11:03 AM Added language correction.
    Monday, October 24, 2011 10:56 AM
  • Thanks for your continued support. The addin does not appear in the disabled section:

     

    I added a message box to the ribbon's constructor, and on my dev machine it pops up just fine:

     

    On the client computer however, nothing happens...

     

     

     

    Monday, October 24, 2011 11:39 AM
  • Hello,

     

    This means that there was a problem with the Installation.  Uninstall it, and look carefully if it is installed sucessfully. Also this means that there is a reference problem. One of the dlls might not be found.

    Take this into account.

     

    PS: Is the Office version on the developing machine the same as the client? Are the prerequisite installed on the clients machine? (for example .net framework, corresponding VSTO kit).

    PPS: Try a remove debugging session, if by chance one of the clients has Visual studio installed.

    Best regards,

    Silviu.


    http://www.rosoftlab.net/
    • Edited by Lupu Silviu Monday, October 24, 2011 11:51 AM Added PPS
    Monday, October 24, 2011 11:49 AM
  • Hi,

     

    It seems to install just fine, I don't know what to look for except what I get from the installer:

     

    The really strange thing about this, is that version 121 of the addin works just fine, while all the later versions I have published fails, and the difference in required prerequisites and references are none - they should not have changed between the versions.

     

    The office versions are the same, .net framework and other prerequisites should be the same - and are also installed automatically as they are included in the setup project from VS:

     

     

    This is starting to get really frustrating...if I could just get an error message or something to indicate what's wrong :-/

     

     

     

     

    Monday, October 24, 2011 12:23 PM
  • Hello,

     

    Check the Control Panel > Event Log > Windows Log (Application / Setup). There should be an eeror there when you open Word and check the add-in to enable it.

     

    Best regards,

    Silviu.


    http://www.rosoftlab.net/
    Monday, October 24, 2011 12:27 PM
  • Unfortunately the event log does not show any entries regarding this when I try to enable the addin - that was one of the first places i checked :-)

    I have run the Process Monitor tool, and filtering only the winword.exe process and paths that contain the name of my addin, and it shows some weird results:

    As you can see, the path in the first two entries does not make sense after the :\ as it says "file:\" and then points to the installation path of the addin.

    I don't know if this has anything to do with the addin not loading, or what to do about this, but it seems strange.

     

    Kind regards

     

     

    Monday, October 24, 2011 12:48 PM
  • Hello,

     

    Remove the addin from Word Add-Ins menu. Remove the Add-in from Add-Remove programs. Restart the computer. In the mean time, make a publish with a different revision number. Make it on Release not Debug. Try to install that one.

    If this does not work either, I would advice trying to get the source on a client machine that was that problem, and attach to the word process, and try to eenable the Add-In from the Word Add-Ins menu. That way you will see the error.

     

    Best regards,

    Silviu.


    http://www.rosoftlab.net/
    Monday, October 24, 2011 1:21 PM
  • Hi,
    For VSTO Add-in not load issue, please follow the steps in this blog:

    My Office Addin does not Load! and tell me the result of the error message.

    I look forward to hearing of you soon.


    Best Regards, Calvin Gao [MSFT]
    MSDN Community Support | Feedback to us
    Get or Request Code Sample from Microsoft
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Tuesday, October 25, 2011 3:33 AM
    Moderator
  • Hello again, sorry for the delayed response.

     

    I tried what you suggested above Silviu, installing the source on the client that did not work and try debugging it. That meant also installing Visual Studio 2008 on the computer.

     

    Attaching to winword.exe process and trying the enable the addin gave no results, it did not jump into Visual Studio or give any error message.

    After words however, I tried publishing the addin to my file server from the client computer, and then re-installing it on the machine from the file server like I always have done, and PRESTO! Somehow the addin now loads like it should!

    So it seems, that for some reason the addin works when published from another machine than my developer machine, even though the code is exactly the same - I just copied the whole Solution to the client computer.

    This solves my immediate urgency problem, but I would prefer to be able to publish from my dev machine, so if anyone can think of a reason for what may be wrong, please do tell me.

     

    Thanks for the help so far!

     

    Wednesday, October 26, 2011 9:55 AM
  • Hello,

     

    Strange. This could still be something related to the office PIA or the VSTO dlls. The reason you could not debug was that the Add-In was not the same as that in your Source. Did your breakpoints had an exclamation mark on them?

     

    Best regards,

    Silviu.


    http://www.rosoftlab.net/
    Wednesday, October 26, 2011 12:19 PM
  • Ok, I thought I had this resolved now but no...

    Now it appears that our Citrix Terminal server users are experiencing problems loading the addin :-(

    The really, really strange thing is that two different users logging on to the same server and running the same version of the addin are experiencing different results, one is getting the addin just fine and the other is not - and it will not load. Both users have the same permissions on the system.

    Now I am even more confused - what is going on here?

     

    Thanks!

     


    EDIT:

    I tried setting the"VSTO_SUPPRESSDISPLAYALERTS" environment variable to 0, to see what the error was, and found that it had to do with access permissions on a file. Changing the permissions seems to have solved this issue also :-)

    • Edited by csharp.net Thursday, October 27, 2011 12:09 PM
    Thursday, October 27, 2011 11:39 AM