locked
Authentication Required on External Site for Internal Domain Users RRS feed

  • Question

  • Greetings -

    Our corporate website is built in SharePoint 2010. We have an intranet version (site.local) for administrators and an extranet version (site.com) for anonymous users.

    Just recently, when internal users attempt to hit the extranet site (site.com), they are prompted for their Windows login into site.local. However, the HTTP redirect in IIS is set up to redirect site.local to site.com. Even if internal users click cancel, any page they navigate to in site.com asks them to authenticate again.

    We did not have this issue before when setting up this site weeks ago.

    Any suggestions on why this is occurring or how to stop the authentication for internal (domain) users? We simply want everyone (except for site administrators) to view the extranet site.

    Thank you for your time!

    Tuesday, November 8, 2011 9:46 PM

Answers

  • I appreciate your quick response!

    To quickly fix the issue, we ended up killing site.local in IIS, which immediately fixed the problem.

    And for the record, 'Anonymous Access' was set properly in Central Admin and in the Site Collection Permissions list.

    • Marked as answer by Seven M Friday, November 18, 2011 6:47 AM
    Wednesday, November 9, 2011 9:14 PM

All replies

  • Hi,

    On the workstation where this issue occurs, please install Fiddler2 (http://www.fiddler2.com/fiddler2/). Then launch it, and then open the site.com and see where you have authentication request or redirection to site.local. 

    I suspect that on site.com there are images or other objects that are taken from site.local, and when accessing them from the outside, it's normal it'll ask to authorize to get them from local resources.

    I assume that you already checked if anonymous access is still enabled on site.com? (both in Central Administration and in Site Collection Permissions)


    Regards, Stanisław Delost, MCP, MCTS, MCITP @ NETPRIME.
    Check my SharePoint Blog
    Wednesday, November 9, 2011 10:22 AM
  • I appreciate your quick response!

    To quickly fix the issue, we ended up killing site.local in IIS, which immediately fixed the problem.

    And for the record, 'Anonymous Access' was set properly in Central Admin and in the Site Collection Permissions list.

    • Marked as answer by Seven M Friday, November 18, 2011 6:47 AM
    Wednesday, November 9, 2011 9:14 PM