none
VS 2015 - Installed VSIX extension is not showing up in the Tools menu

    Question

  • Use Case
    - Create Project using File => New Project => Installed => Templates => Other Languages => Visual C# => Extensibility => VSIX Project

    - Right Click on Project => Add New Item => Visual C# Items => Extensibility => VSPackage => Custom Command

    - Change auto-load data to [ProvideAutoLoad(UIContextGuids80.NotBuildingAndNotDebugging)]

    - Edit MenuItemCallback to provide useful functionality.

    - Test extension in Experimental Instance.  My command appears at the top of the Tools Menu and performs as expected.

    - Exit VS 2015

    - Double click on .VSIX file in my project\bin\Release folder.  VSIX installer launches. There is a warning about the VSIX file not being digitally signed.  OK the install.

    - Launch VS 2015

    - Tools => Extensions and Updates.  Extension does appear in Extensions and Updates window. VS 2015 indicates that it is installed and enabled.

    - Extension does not appear in Tools menu.

    Is there a step I am missing to get a VSIX extension to work in VS 2015?  Registration with Microsoft?  Digital signing?  Some other setting?

    Friday, August 12, 2016 9:27 PM

Answers

  • Hi iseale,

    Thanks for your post.

    I follow the steps your shared and I can install my VSIX project into the Visual Studio Extension successfully.

    Please restart the Visual Studio again to check whether you can find the VSIX project in the Extension.

    If still can't find it. Please try running your Visual Studio in Safe mode to Check whether some add-ins and extensions affect it (devenv /safemode)

    Then create a new VSIX project, add a Custom Command, build the project in Debug module then install it.

    If still can't find the new VSIX project. I suppose there might be something wrong with your Visual Studio. Please try to repair your Visual Studio or install the VS2015 Update3, the latest update of Visual Studio.

    Best Regards,

    Lake Xiao

    Saturday, August 13, 2016 3:34 AM
    Moderator