none
Attempt to install DNS Server failed with error code 0x80070643. Fatal error during installation RRS feed

  • Question

  • I have been trying to install DNS role on my server, it has become a frustration and pain point, I keep getting this error. Any way I have already downloaded HotFix Windows6.0-KB975654-x64 for my server, and followed instrcutions to install a patch to remove restrictions for network adapters, I have a 2 port Intel server adapter as well as a 4 port Intel server adapter, Iorigiannly had all 6 teamed, but I took a chance and removed one from the team and assigned it a static so I could attempt installing DNS role after patch with a 5 port team and a standalone port, both have static IPs. but I keep getting the same error.

    If anyone has an idea I am more than happy to provide logs, or anything necessary to get this role installed, and working

    Jaime

    Wednesday, June 2, 2010 11:00 PM

All replies

  • In my case I had changed the default dynamic port range to only 255 ports. I changed the setting back to 16383 ports and was able to install DNS without any error.

    You can refer to http://support.microsoft.com/kb/929851 for more information about default ports.

    Thanks

    Deval

    • Proposed as answer by Dev_al1 Friday, January 21, 2011 12:42 PM
    Friday, January 21, 2011 12:42 PM
  • Thank you very much Deval!!, I have been pulling out my hair trying to figure out why DNS won't install.... then reading this post I remembered I had to to change the RPC dynamic range down to 255 like yourself, changing it back to defaults work like a charm, wish I can give you more points!
    Thursday, March 17, 2011 6:28 PM
  • This was indeed a solution for me also! Any idea why this fails when using a smaller range?

    I changed the range after the installation and DNS still works fine. So this is only a requirement at installation time?

    Friday, April 1, 2011 12:25 PM
  • Hi Stijn VdB ,

    Please give vote incase my answer helped you.

    Thanks

    Wednesday, December 21, 2011 9:38 AM
  • Followed your advise as I had configured only 500 dynamic ports for RPC (as per security's recommdation).  All other TCP/IP settings on the DCs were static and AD DS was fully functional (minus getting the DNS role on the rest of my DCs).

    Tried everything I could think of but the DNS role would simply not install.  Increased the ports to 2000 and DNS loaded without any issues.    

    Thanks,

    Phillip

    Thursday, March 1, 2012 10:43 PM
  • i had the same problem and did the following command and removed the IP of DNS server

      this command will set the port no for DNS

    • netsh int ipv4 set dynamicport tcp start=10000 num=1000
    • netsh int ipv4 set dynamicport udp start=10000 num=1000
    • netsh int ipv6 set dynamicport tcp start=10000 num=1000
    • netsh int ipv4 set dynamicport udp start=10000 num=1000


    Thanks Ajay Singh MCITP Exchange IBM Tivoli, HP DPS,

    • Proposed as answer by Ajay.Singh Friday, April 20, 2012 7:49 AM
    Tuesday, March 13, 2012 5:22 AM