locked
Microsoft_Azure_DataFactory extension failed to load RRS feed

  • Question

  • When trying to create or edit an Azure Data Factory resource, I am getting error as "Microsoft_Azure_DataFactory extension failed to load"
    Tuesday, November 20, 2018 9:29 AM

All replies

  • Hi Sujal,

    Did you try to refresh the page? What kind of ADF resource were you creating/editing? Does this issue still exist? We need more information to debug. :)

    Thanks.

    Thursday, November 22, 2018 2:31 PM
  • Yes tried refresh enough number of times. I am trying to create an Azure Data Factory resource in the Azure portal. Also the same error is thrown if I try to open any of the existing Azure Data Factory created by my teammates.

    Surprisingly, if i try to open any other resource such as SQL server or any Storage Accounts they are opening with no problems at all. 

    Monday, November 26, 2018 7:53 AM
  • Hello Sujal, 

    You might be having a permissions issue although I have not seen the particular error you are getting in relation to permissions.  Take a look here at permissions:

    https://docs.microsoft.com/en-us/azure/data-factory/concepts-roles-permissions

    • Proposed as answer by Jason_J (Azure) Tuesday, November 27, 2018 12:42 AM
    Tuesday, November 27, 2018 12:42 AM
  • Thanks Jason. But my issue is not listed here.

    Well yesterday, I tried to replicate the issue from home using my personal laptop connected to my home network and I was able to access the ADF resource with no problems at all.

    However when I again tried to access the ADF resource from my office desktop, the issue seems to have appeared again. Reached out to the networking team and they are saying that I am on the same VLAN as rest of my teammates and all the firewall rules are same for all the persons in the network. 

    Please note that my teammates are able to access the ADF resource with ease.

    Do you have any other suggestions I should lookout for?

    Regards
    Sujal

    Tuesday, November 27, 2018 8:13 AM