locked
Batch nodes in a Vnet can not connect to VMs in peered Vnets RRS feed

  • Question

  • hi,



    I am using Iaas Pool with a Azure resource manager Vnet(Name: Vnet-1).

    Vnet-2 is another Azure resource manager Vnet in different region.

    Vnet-1 is peered to Vnet-2 via Global peer.



    Problem:

    Batch node can not get access to a VM in Vnet-2. However, If I manually create a Vm inside Vnet-1, then it can get access to the VM in Vnet-2. 

    so where could go wrong? I already check the NSG, no problem found.

    Thanks.


    Tuesday, April 17, 2018 8:35 PM

All replies

  • What error do you see when the batch node tries to connect? 
    Monday, April 23, 2018 3:04 AM
  • I tried ping and telnet from a batch node, and both can not go through.

    However, in a manually created VM, in the same Vnet, both are fine.

    Monday, April 23, 2018 2:59 PM
  • What OS are you using? You might need to check the firewall settings as well. 
    Monday, April 23, 2018 6:59 PM
  • I am using

    OS: microsoft-ads standard-data-science-vm standard-data-science-vm (latest)

    I have checked fire wall settings on my batch node, nothing block outbound traffic.

    For the  VM in Vnet-2, since it can already be access by manually created VM in Vnet-1, its firewall should have no problem.

    Monday, April 23, 2018 7:22 PM
  • Can you try adding another Vm to your batch pool and make it a standard Windows Server machine? That way we can determine if it is an issue with the VM in the Batch pool or with the data science image itself. 
    Tuesday, April 24, 2018 6:22 PM
  • Just tried with standard win server, and it has the same issue.

    Tuesday, April 24, 2018 8:15 PM
  • So seems to be an issue with how Batch is configured. 

    I found the following which might help: 

    https://docs.microsoft.com/en-us/azure/batch/batch-virtual-network

    Can you walk through this doc to ensure we have it all setup correctly? 

    Tuesday, April 24, 2018 11:52 PM