locked
How to open a website in localhost.. RRS feed

  • Question

  • User1357926729 posted

    Hi..

    Can someone tell me in detail how to open a website in localhost from a computer which is in the LAN.can u tell me the steps which i should follow in IIS manager.I am using windows 7 and VS 2010.My aplication name is HR portal..Its really urgent..Hope someone will help me soon.

    Sunday, April 28, 2013 9:11 AM

Answers

  • User-623947428 posted

    first install iis, follow the link to

    1) install iis http://www.iis.net/learn/install/installing-iis-7/installing-iis-on-windows-vista-and-windows-7

    2) open run command type inetmgr....... then from default website right click and add application name 'HRPortal'

    3) set the default document of your application for eg:index.aspx

    4) open any browser and enter  http:// [computername]/HRPortal/index.aspx

    5) then go to Control Panel\System and Security\Windows Firewall and select option Allowed Programs or features through windows firewall make sure that world wide web services (http) is checked.

    6) make sure that lan is available from other pc and from the other client pc open the broweser and enter the same url 

    http:// [computername]/HRPortal/index.aspx

    7) thats it ....

    allow iis from firewall

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Sunday, April 28, 2013 9:52 AM
  • User-623947428 posted

    1) give the alias name HRPortal 

    2) give the physical path of your application  where its located eg( d:\HRPortal)

    3) keep  the default application pool

    4) for setting default page see the following image in the feature view there is option called defaut document..

    default document in iis

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Monday, April 29, 2013 1:56 AM
  • User1357926729 posted

    My Issue is solved.Installed IIS again.U have to log in as Administrator to register IIS.Now its working.

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Tuesday, April 30, 2013 4:24 AM

All replies

  • User-623947428 posted

    first install iis, follow the link to

    1) install iis http://www.iis.net/learn/install/installing-iis-7/installing-iis-on-windows-vista-and-windows-7

    2) open run command type inetmgr....... then from default website right click and add application name 'HRPortal'

    3) set the default document of your application for eg:index.aspx

    4) open any browser and enter  http:// [computername]/HRPortal/index.aspx

    5) then go to Control Panel\System and Security\Windows Firewall and select option Allowed Programs or features through windows firewall make sure that world wide web services (http) is checked.

    6) make sure that lan is available from other pc and from the other client pc open the broweser and enter the same url 

    http:// [computername]/HRPortal/index.aspx

    7) thats it ....

    allow iis from firewall

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Sunday, April 28, 2013 9:52 AM
  • User1357926729 posted

    2) open run command type inetmgr....... then from default website right click and add application name 'HRPortal'

    3) set the default document of your application for eg:index.aspx

    4) open any browser and enter  http:// [computername]/HRPortal/index.aspx

    Thanks a lot for the detailsed reply..still i have doubts.from the default website,add application window opened.what should i give the alias name?should i give it just 'HRPortal'? What should i give the physical path?should i put the folder containing my application in inetpub->wwwroot before doing all these and should i give the physical path as the path to wwwroot or to my orginal folder containing the application.Sould i change the application pool options to asp.net v4.0?or should it remain as defaultApplicationPool.

    You have also said about setting the default document of your application.how should i set it.is it something to do in this IIS manager page?my default page is login.aspx.But i cant see these pages in the HRPortal folder which has come under defaultwebsite.i can see only folders like bin,images and JS.

    Hope u'll help me soon..

    Monday, April 29, 2013 1:41 AM
  • User-623947428 posted

    1) give the alias name HRPortal 

    2) give the physical path of your application  where its located eg( d:\HRPortal)

    3) keep  the default application pool

    4) for setting default page see the following image in the feature view there is option called defaut document..

    default document in iis

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Monday, April 29, 2013 1:56 AM
  • User1357926729 posted

    Thanks again for the quick reply...

    I did everythingwhat u told.Then when i right click HRportal folder under the default website->manage application ->browse-> the explorer page opens with URL http://localhost:51326/HRPortal.

    login.aspx is not coming here.when i added it like /login.aspx,still no use.the page shows internet explorer cannot display the web page.So how should i browse it.Another problem is i am logged in to my system as user not administrator.is it a problem?do i have anything to do at HRportal right click->edit permissions->security...

    plss help.

    Monday, April 29, 2013 2:11 AM
  • User1357926729 posted

    my system name is user-pc.So i tried to browse like this also..

    http://user-pc/HRPortal/login.aspx

    but no use..error msg is HTTP 404 not found.

    Monday, April 29, 2013 2:15 AM
  • User-623947428 posted

    Just enter localhost in the browser and let me know.....

    Monday, April 29, 2013 2:19 AM
  • User1357926729 posted

    if i enter just localhost,result is web page cannot be found. if i enter http://localhost/HRPortal/login.aspx the same result.

    Monday, April 29, 2013 2:41 AM
  • User1357926729 posted

    Is it necessary to log in as administrator to open the website in localhost?i dont have Visual Studio in administrator Log in..should i install it in that login and configure IIS from beginning..Please advice..

    Monday, April 29, 2013 3:22 AM
  • User1357926729 posted

    My Issue is solved.Installed IIS again.U have to log in as Administrator to register IIS.Now its working.

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Tuesday, April 30, 2013 4:24 AM