none
Exchange 2010 sp3 failed on hub transport role install RRS feed

  • Question

  • I have 2 CAS and 2 DAG Exchange servers on Exchange 2010 SP2. When I try to install Exchange SP3 on my CAS server I get the following error on the  hub transport role install. Any suggestions?


    Summary: 7 item(s). 3 succeeded, 1 failed.
    Elapsed time: 00:17:23


    Language Files
    Completed

    Elapsed Time: 00:09:55


    Restoring services
    Completed

    Elapsed Time: 00:00:16


    Languages
    Completed

    Elapsed Time: 00:02:42


    Hub Transport Role Failed Error: The following error was generated when "$error.Clear(); 
              $vdirName = "PowerShell (Default Web Site)";
              $proxyVdirName = "PowerShell-Proxy (Default Web Site)";
              $InternalPowerShellUrl="http://" + $RoleFqdnOrName + "/powershell";
              $vdir = get-PowerShellVirtualDirectory -server $RoleFqdnOrName -DomainController $RoleDomainController | where { $_.Name -eq $vdirName };
              $proxyVdir = get-PowerShellVirtualDirectory -server $RoleFqdnOrName -DomainController $RoleDomainController | where { $_.Name -eq $proxyVdirName };
              
              if ($vdir -ne $null -or $proxyVdir -ne $null)
              {
                update-PowerShellVirtualDirectoryVersion -DomainController $RoleDomainController;
              }

              if ($vdir -eq $null)
              {
                $vdirName = "PowerShell";
                new-PowerShellVirtualDirectory $vdirName -InternalUrl $InternalPowerShellUrl -DomainController $RoleDomainController -BasicAuthentication:$false -WindowsAuthentication:$false -RequireSSL:$false;
              }
              else
              {
                Set-PowerShellVirtualDirectory $vdirName -InternalUrl $InternalPowerShellUrl -DomainController $RoleDomainController -WindowsAuthentication:$false -RequireSSL:$false;
              }

              if ($proxyVdir -eq $null)
              {
                $proxyVdirName = "PowerShell-Proxy";
                new-PowerShellVirtualDirectory $proxyVdirName -DomainController $RoleDomainController -BasicAuthentication:$false -WindowsAuthentication:$true -RequireSSL:$true -AppPoolId "MSExchangePowerShellProxyAppPool" -Path ($RoleInstallPath + "ClientAccess\PowerShell-Proxy");
              }
              else
              {
                Set-PowerShellVirtualDirectory $proxyVdirName -DomainController $RoleDomainController -WindowsAuthentication:$true -RequireSSL:$true;
              }
            " was run: "A failure occurred while trying to update metabase properties.".

    A failure occurred while trying to update metabase properties.

    The system cannot find the path specified.

    Click here for help... http://technet.microsoft.com/en-US/library/ms.exch.err.default(EXCHG.141).aspx?v=14.3.123.3&e=ms.exch.err.Ex88D115&l=0&cl=cp

    Elapsed Time: 00:04:28


    Client Access Role
    Cancelled




    Management Tools
    Cancelled




    Finalizing Setup
    Cancelled


    Wave~Chaser

    Wednesday, August 7, 2013 12:09 AM

All replies

  • We are seeing the same error in our environment.  Did you figure out what was causing it?

    Marc

    Wednesday, September 25, 2013 3:33 PM
  • Ya I reverted to a snapshot of my CAS server. Never use a spanshot of a vm for Exchange. I had to rebuilt the CAS server using Exchange recovery. The above error was related to a broken virtual directory, so you might be able to rebuild it?

    Wave~Chaser

    Wednesday, September 25, 2013 3:37 PM