none
Unwanted Spaces in 834 EDI message RRS feed

  • Question

  • Hi Team,

    Please help on below issue .

    Am generating 834 EDI file from DB.

    In My process for each of loop from orchestration am generating EDI file and for the same generated file am appending data's using Port Property COPY MODE set to APPEND.

    Pipeline : Default EDI send.

    The generated file looks like below without issues 

    ISA*00*.........:~
    GS.......~
    ST*.........~
    BGN*............~
    N1*............~
    N1*........~
    INS..........~
    ;
    ;
    ;

    SE*....~
    GE*....~
    IEA*1*000000001~
    ISA*00*.........:~
    GS.......~
    ST*.........~
    BGN*............~
    N1*............~
    N1*........~
    INS..........~
    ;
    ;
    ;

    SE*....~
    GE*....~
    IEA*1*000000001~
    ISA*00*.........:~
    GS.......~
    ST*.........~
    BGN*............~
    N1*............~
    N1*........~
    INS..........~
    ;
    ;
    ;

    SE*....~
    GE*....~
    IEA*1*000000001~

    In few cases while generating am facing issues. The generated file having Extra space, improper Segment  like below

    1. Empty space between two messages in a single file.

    ISA*00*.........:~

    GS.......~

    ST*.........~

    BGN*............~

    .

    .

    SE*....~

    GE*....~

    IEA*1*000000001~

    ISA*00*.........:~

    GS.......~

    ST*.........~

    BGN*............~

    N1*............~

    N1*........~

    INS..........~

    ;

    ;

    ;

    .

    SE*....~

    GE*....~

    <--- EMPTY SPACE--->

    IEA*1*000000001~

    ISA*00*.........:~

    GS.......~

    ST*.........~

    BGN*............~

    N1*............~

    N1*........~

    INS..........~

    ;

    ;

    ;

    SE*....~

    GE*....~

    IEA*1*000000001~

    2. Improper segment between  2 messages.

    a.

    ISA*00*.........:~

    GS.......~

    ST*.........~

    BGN*............~

    .

    .

    SE*....~

    GE*....~

    IEA*1*000000001~

    ISA*00*.........:~

    GS.......~

    ST*.........~

    BGN*............~

    N1*............~

    N1*........~

    INS..........~

    ;

    ;

    ;

    .

    SE*....~

    GE*....~

    IEA*1*000000001~

     *91~

    ISA*00*.........:~

    GS.......~

    ST*.........~

    BGN*............~

    N1*............~

    N1*........~

    INS..........~

    ;

    ;

    ;

    SE*....~

    GE*....~

    IEA*1*000000001~

    b. Improper message between Two Proper EDI message

    ISA*00*.........:~

    GS.......~

    ST*.........~

    BGN*............~

    .

    .

    SE*....~

    GE*....~

    IEA*1*000000001~

    ISA*00*.........:~

    GS.......~

    ST*.........~

    BGN*............~

    N1*............~

    N1*........~

    INS..........~

    ;

    ;

    ;

    .

    SE*....~

    GE*....~

    IEA*1*000000001~

    N1*…. ~

    ;

    ;

    .

    SE*....~

    GE*....~

    IEA*1*000000001~

    ISA*00*.........:~

    GS.......~

    ST*.........~

    BGN*............~

    N1*............~

    N1*........~

    INS..........~

    ;

    ;

    ;

    SE*....~

    GE*....~

    IEA*1*000000001~

    Please help to resolve the same

    Thursday, February 9, 2017 10:04 AM

Answers

  • Do any of the message appear malformed when not using Append?

    Try with Ordered Delivery checked on the Send Port.

    Finally, you really shouldn't be doing this in the first place.  The correct way to batch EDI is with the Batching Service.

    Thursday, February 9, 2017 1:20 PM