locked
Promted for a login to SQL Server and an error

    Question

  • I try to set up a connection to SQL Server 2012 on my laptop(Excel 2013 and SQL Server 2012 on the same machine) and I get this error: provider: SSL-provider, error: 31.

    Is this a bug. I have the same issue on two laptops(Windows 7 and Windows 8) with the same setup.

    Any ideas?

    Thomas Ivarsson

    Friday, March 01, 2013 1:39 PM

Answers

  • Hi Thomas,

    I tried the same scenario and it worked in my machine. This could be configuration issue about the SQL server.

    Can you please try the following steps to see if your issue is resolved?

    1. Open "SQL Server Configuration Manager".

    2. Expand "SQL Server Network Configuration", select your SQL server instance, then right click and select properties.

    3. In the "Flags" tab, in the general section, there is a drop down called "Force Encryption". It is by default turned off. Can you please check if you turned it on? If yes, then SQL server will require SSL to be used on all connections. You may turn it off to get the Data Explorer connection work, but you should decide the value for this configuration based on you own security requirement.

    Hope this is helpful to you.

    Regards

    Qunshu


    Clarification: Microsoft doesn't own any liability & responsibility for any of my posting.


    Friday, March 01, 2013 5:45 PM

All replies

  • Hi Thomas,

    I tried the same scenario and it worked in my machine. This could be configuration issue about the SQL server.

    Can you please try the following steps to see if your issue is resolved?

    1. Open "SQL Server Configuration Manager".

    2. Expand "SQL Server Network Configuration", select your SQL server instance, then right click and select properties.

    3. In the "Flags" tab, in the general section, there is a drop down called "Force Encryption". It is by default turned off. Can you please check if you turned it on? If yes, then SQL server will require SSL to be used on all connections. You may turn it off to get the Data Explorer connection work, but you should decide the value for this configuration based on you own security requirement.

    Hope this is helpful to you.

    Regards

    Qunshu


    Clarification: Microsoft doesn't own any liability & responsibility for any of my posting.


    Friday, March 01, 2013 5:45 PM
  • Hi,

    It did not solve this issue. If i switch that setting the same error appears.

    BR

    Thomas Ivarsson


    Monday, March 04, 2013 4:32 PM
  • Hi Thomas,

    Are you accessing this server through the internet? For internet databases we always require encryption and the certificate test to pass by specifying “Encrypt=true;TrustServerCertificate=falsein the connecting string, so the workaround would be to fully support encryption with a valid certificate on the server side. Currently we are investigating a feature that would allow the user to opt out of this encryption requirement, however it has not been implemented yet.

    Thanks,

    Theresa

    Wednesday, March 06, 2013 12:05 AM
  • Hi Theresa,

    It is probably named pipes or shared memory since the SQL Server 2012 database is on my laptop together with Excel 2013 and Data Explorer. Tcp/Ip is activated as well.

    BR

    Thomas Ivarsson


    Thursday, March 07, 2013 7:21 PM
  • it is a bug. version 1.1.3232.4 will work.
    Tuesday, March 12, 2013 9:09 PM
  • I can confirm that. With the latest update it works.

    BR

    Thomas Ivarsson

    Wednesday, March 13, 2013 6:20 AM