none
Volume filter Logo Testing RRS feed

  • Question

  • Hello,

    We are developing higher level volume filter driver but for logo testing following tests are failed:
    1. Disable Enable With IO
    a. Execute Disable_Enable_With_IO Script
    b. Execute Device_Status_Check Script

    2. Common Scenario Stress With IO
    a. Execute Common_Scenario_Stress_With_IO Script
    b. Execute Device_Status_Check Script

    Error for above test:
    a. SimpleIOStress Failed! -> IcmpSendEcho() had too many consecutive timeouts. Win32=11010 - Error due to lack of resources.
    b. Device has issues and not ready for test. Device Problem Code is: 28

    Has anyone encountered such problems? Any pointers that will be helpfull.

    Regards,
    Rajendra

    Wednesday, December 19, 2012 5:33 AM

All replies

  • Hi,

    Make sure you have configured IPs (v4 & v6) on each client machine.

    Set Server's IPv6 address as IPv6 gateway address on each client machine, and,

    Set Server's IPv4 address as IPv4 gateway address on each client machine.

    Refer: http://social.msdn.microsoft.com/Forums/en-US/whck/thread/22c90cfd-46f2-44ec-8189-baf21b610c60

    Wednesday, December 19, 2012 6:18 AM
  • Hello Nilesh,

    Thanks for reply.

    As per your suggestion, we configured the network. But still same error occurred.

    Instead we set the gateway on both machine to ZERO, most of the test cases gets passed while following sub-test cases failed:

    1. Disable Enable With IO
    a. Execute Device_Status_Check Script

    2. Common Scenario Stress With IO
    a. Execute Device_Status_Check Script

    Error for above test:
    a. Device has issues and not ready for test. Device Problem Code is: 28

    Any pointers that will be helpful.

    Thanks & Regard,
    Rajendra


    Friday, December 21, 2012 9:08 AM
  • Hi Rajendra,

    "Instead we set the gateway on both machine to ZERO"

    I would like to know, what IP related configuration you have on each of the computers in your network including server machine.

    Thanks,

    Nilesh

    Friday, December 21, 2012 9:28 AM
  • Hello Nilesh,

    As per your suggestion I set the network configuration as:
    Client Machine(Windows XP): 
    IPV4: 172.16.4.24
    Subnet Mask: 255.255.240.0
    Gateway: 172.16.4.21

    Controller Machine(Windows Server 2008 R2): 
    IPV4: 172.16.4.21
    Subnet Mask: 255.255.240.0
    Gateway: (Empty)

    IPV6: Not configured

    Thanks & Regards,
    Rajendra
    Friday, December 21, 2012 10:06 AM
  • Hi Rajendra,

    The configuration is correct, now it should resolve the error related to IcmpSendEcho().

    For the "Device has issues" error, can you provide the log containing this error message?

    Thanks,

    Nilesh.

    Friday, December 21, 2012 10:37 AM
  • Title Result
    Device(s) Under Test must be enabled and problem free in order for further test results to be valid.{ADCBD191-16E8-11DB-B50B-0010C65AFEB5}" Failed
    Start Test 12/21/2012 12:25:48.421 AM Device(s) Under Test must be enabled and problem free in order for further test results to be valid.{ADCBD191-16E8-11DB-B50B-0010C65AFEB5}
    Message 12/21/2012 12:25:48.421 AM Test Version: 1.0
    Message 12/21/2012 12:25:48.421 AM IODevices: 'IsPhantom=False AND IsRootEnumerated=False AND ClassGUID!='{533C5B84-EC70-11D2-9505-00C04F79DEAF}' AND parent/service!=swenum'
    Message 12/21/2012 12:25:48.421 AM WARNING: Device doesn't have a driver installed on it: 'PCI\VEN_8086&DEV_2772&SUBSYS_D6068086&REV_02\3&61AAA01&0&10'
    Message 12/21/2012 12:25:48.421 AM WARNING: Device doesn't have a driver installed on it: 'PCI\VEN_8086&DEV_27D8&SUBSYS_D6068086&REV_01\3&61AAA01&0&D8'
    Message 12/21/2012 12:25:48.421 AM Checking the status of each devices.
    End Test 12/21/2012 12:25:48.421 AM Device(s) Under Test must be enabled and problem free in order for further test results to be valid.{ADCBD191-16E8-11DB-B50B-0010C65AFEB5}
    Result: Fail
    A - Device(s) under test should all be enabled and functional for testing. {DEAD4AFD-658E-451c-A95F-9AEB6922ED29}" Failed
    Start Test 12/21/2012 12:25:48.421 AM A - Device(s) under test should all be enabled and functional for testing. {DEAD4AFD-658E-451c-A95F-9AEB6922ED29}
    End Test 12/21/2012 12:25:48.421 AM A - Device(s) under test should all be enabled and functional for testing. {DEAD4AFD-658E-451c-A95F-9AEB6922ED29}
    Result: Fail

    Verifying Device ID: PCI\VEN_8086&DEV_2772&SUBSYS_D6068086&REV_02\3&61AAA01&0&10 - undefined"

    Failed
    Start Test 12/21/2012 12:25:48.421 AM A.Verifying Device ID: PCI\VEN_8086&DEV_2772&SUBSYS_D6068086&REV_02\3&61AAA01&0&10 - undefined
    Message 12/21/2012 12:25:48.421 AM DeviceID: PCI\VEN_8086&DEV_2772&SUBSYS_D6068086&REV_02\3&61AAA01&0&10
    Message 12/21/2012 12:25:48.421 AM Name: Video Controller (VGA Compatible)
    Message 12/21/2012 12:25:48.421 AM Class: {4D36E97E-E325-11CE-BFC1-08002BE10318}
    Message 12/21/2012 12:25:48.421 AM Device has issues and not ready for test. Device Problem Code is: 28
    Message 12/21/2012 12:25:48.421 AM Device has issues and not ready for test. Device Status Code is: 25175040
    Error 12/21/2012 12:25:48.421 AM Device has issues and not ready for test. Device Problem Code is: 28
    File: . Line: 0
    Error Type: HRESULT
    Error Code: 0xffffffff
    Error Text: Error 0xffffffff
    End Test 12/21/2012 12:25:48.421 AM A.Verifying Device ID: PCI\VEN_8086&DEV_2772&SUBSYS_D6068086&REV_02\3&61AAA01&0&10 - undefined
    Result: Fail
    A.Verifying Device ID:  PCI\VEN_8086&DEV_27D8&SUBSYS_D6068086&REV_01\3&61AAA01&0&D8 - undefined"  Failed
    Start Test 12/21/2012 12:25:48.421 AM A.Verifying Device ID: PCI\VEN_8086&DEV_27D8&SUBSYS_D6068086&REV_01\3&61AAA01&0&D8 - undefined
    Message 12/21/2012 12:25:48.421 AM DeviceID: PCI\VEN_8086&DEV_27D8&SUBSYS_D6068086&REV_01\3&61AAA01&0&D8
    Message 12/21/2012 12:25:48.421 AM Name: PCI Device
    Message 12/21/2012 12:25:48.421 AM Class: {4D36E97E-E325-11CE-BFC1-08002BE10318}
    Message 12/21/2012 12:25:48.421 AM Device has issues and not ready for test. Device Problem Code is: 28
    Message 12/21/2012 12:25:48.421 AM Device has issues and not ready for test. Device Status Code is: 25175040
    Error 12/21/2012 12:25:48.421 AM Device has issues and not ready for test. Device Problem Code is: 28
    File: . Line: 0
    Error Type: HRESULT
    Error Code: 0xffffffff
    Error Text: Error 0xffffffff
    End Test 12/21/2012 12:25:48.421 AM A.Verifying Device ID: PCI\VEN_8086&DEV_27D8&SUBSYS_D6068086&REV_01\3&61AAA01&0&D8 - undefined
    Result: Fail

    Friday, December 21, 2012 11:12 AM
  • Hello Nilesh,

    I have provided(previous reply) the error of logo testing.

    Thanks & Regards,
    Rajendra

    Friday, December 28, 2012 11:02 AM
  • Hi Rajendra,

    Sorry for late reply.

    There are some devices which are not working properly on your system, thus causing failure. In log you can see the respective DeviceIDs, open Device manager "devmgmt.msc" and check out for these devices and make sure they are working as expected.

    Regards,

    Nilesh

    Monday, December 31, 2012 6:35 AM