locked
Unable to connect to WPA2-Enterprise Wifi

    Question

  • Hello, I have an Asus EP121 tablet and am trying to connect to my organization's Enterprise Wifi. Wifi had been working perfectly on Windows 7 Enterprise. I installed Windows 8 Developer Preview, Installed all Windows Updates, Synced Date/Time, joined the windows domain, then disconnected my LAN connection and tapped on the wifi connection. It prompted me with 3 buttons (Username and Password, Use Windows Credentials, and Certificate), I tapped certificate (certificate is in the personal store) and it basically spins for 2 minutes and times out with "Windows was unable to connect to <WLAN NAME>". So, I reinstalled and setup Windows 7 and exported the working profile file using this command: C:\>netsh wlan export profile name="102nd" Then I reinstalled Windows 8 Dev Prev and added the profile using: C:\>netsh wlan add profile filename="wireless network connection-102nd.xml" Then I tried to connect again and still no luck with the profile. This time, I was not prompted with the 3 buttons, but still got the same timeout message as before after 2 minutes. While it is trying to connect, I noticed the Adapter status in the Classic UI shows "Attempting to authenticate" until it fails, then shows not connected. It does not do that when I connect without using the imported profile... Also, connecting to a public Wifi works fine, so there is no hardware/driver issue. I have seen other threads similar to this, but no answers... Also, in the Windows Applications Event log, usually reports this error when I try to connect: Could not find the requested EapMethod: TypeId(0), AuthorId(0), VendorId(0), VendorType(0) Thanks, Valkyrie-MT
    Tuesday, December 06, 2011 11:40 PM

Answers