none
Bower package manager in Visual studio 2015 does not find bower packages

    Question

  •  I am using Bower package manager available in Visual Studio 2015. I have created and registered my own Bower package using bower tools. It is serchable through Bower.io web site and internal tools, but it is not displayed using Bower package manager in Visual Studio 2015.

    Further research showes that there is a large number of such packages, that can not be found using Bower package manager in VS2015. Moreover the installed packages are not shown on Installed Tab. This makes it unsyncronized with the Dependencies reference in Solution Explorer for current project.

    What is the filter for Bower packages in Bower package Manager window? And why this filtering happens?

    Example: 

    Compare search results in Visual Studio Bower package manager and https://bower.io/search/ using i.e. 'web-' query string. It is reproducable also with other search queries.

    Tuesday, August 30, 2016 11:29 AM

All replies

  • Hi ElenaLenchic,

    >>Moreover the installed packages are not shown on Installed Tab.

    In my side, I installed some packages, and when I click the Installed Tab they are shown there. Please make sure the search bar is empty when you click Installed Tab.

    >>What is the filter for Bower packages in Bower package Manager window? And why this filtering happens?

    Filter for Bower packages means include/exclude files for Bower dependency. We need to install bower-installer to filter the files that we want, please refer to this thread:

    http://stackoverflow.com/questions/22263820/filter-include-exclude-files-for-bower-dependency

    >>Compare search results in Visual Studio Bower package manager…

    In my side I encountered the same issue as you. This could be caused by the compatibility between Manage Bower Packages and IE browser. When I type query string “web-“ in Manage Bower Package, and two options have been listed.  However, when I typed it in Search package web with IE, there was nothing listed. And when I typed it with Edge browser that there were many packages beginning with “web-” listed. As my understanding, this may be caused by the compatibility between bower and IE. I suggest you could submit a feedback about this issue to the following link:

    https://github.com/bower/bower.github.io/issues

    Sincerely,

    Oscar


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place. Click HERE to participate the survey.

    Wednesday, August 31, 2016 12:09 PM
    Moderator
  • Hi Oscar,

    Thanks for the reply. 

    >>>>Moreover the installed packages are not shown on Installed Tab.

    >>In my side, I installed some packages, and when I click the Installed Tab they are shown there. Please make sure the search bar is empty when you click Installed Tab.

    I would like to describe it more detailed. If I install packages (that are not displayed in Browse Tab) using console, these packages are not displayed in Installed Tab either. But its dependencies do. It looks strange. Search box is empty.

    >> Filter for Bower packages means include/exclude files for Bower dependency. We need to install bower-installer to filter the files that we want, please refer to this thread:

    http://stackoverflow.com/questions/22263820/filter-include-exclude-files-for-bower-dependency

    No, I did not mean this. I meant only available packages list...

    And about seraching using IE it actually does not work!!! This makes sence. I have tried to search in https://bower.io/search/ directly from Visual Studio. It hangs with "Loading search results... "

    There is also a note 

    Please note that GitHub no longer supports old versions of Internet Explorer.

    We recommend upgrading to the latest Internet Explorer, Google Chrome, or Firefox.

    If you are using IE 11, make sure you turn off "Compatibility View".

    Wednesday, August 31, 2016 1:39 PM
  • Hi ElenaLenchic,

    Thank you for your response.

    >>If I install packages (that are not displayed in Browse Tab) using console, these packages are not displayed in Installed Tab either

    I encountered the same issue as you, if I install the package from command line, then it would be no displayed in Installed Tab immediately. This is because Manage Bower Packages has not been refreshed. We could close it and reopen it again, then all installed packages are listed in Installed Tab.

    >>What is the filter for Bower packages in Bower package Manager window? And why this filtering happens?

    >>I meant only available packages list

    When we type something in search box, the filter feature will be started to find corresponding packages.

    It helps us quickly find the most closely compatible packages.

    But the issue that list options were different in Bower Package Manager and Bower Search Web, I think this may be related to the filter in Bower Package Manager. I suggest you could submit a feedback to the last link of my fist reply. I think engineers will evaluate this issue seriously.

    Sincerely,

    Oscar


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place. Click HERE to participate the survey.

    • Proposed as answer by qing__Moderator Thursday, September 8, 2016 3:34 AM
    • Unproposed as answer by qing__Moderator Thursday, September 8, 2016 1:03 PM
    Thursday, September 1, 2016 8:54 AM
    Moderator
  • I have posted a question there, but for sure it is not the problem of Bower itself, because bower search in command line and on the web site works well. But there is some problem with the integration with Visual Studio that may be somehow related to IE issue. I've tried to search packages in Edge, but I have got and exception in console: 

    SCRIPT5009: 'Promise' is undefined

    File: index.js, Line: 1164, Column: 33

    Thursday, September 1, 2016 2:20 PM
  • Hi ElenaLenchic,

    As far as I know, when we search packages with VS, and VS will call IE core by default.

    >>I've tried to search packages in Edge, but I have got and exception in console:

    Would you please share me which package you searched in Edge, which could help me to repro your issue in my side?

    Sincerely,

    Oscar


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place. Click HERE to participate the survey.

    Friday, September 2, 2016 9:15 AM
    Moderator
  • >>Would you please share me which package you searched in Edge, which could help me to repro your issue in my side?

    Actually I haven't typed anything. It just breaks down without any query string while loading most popular packages.

    Friday, September 2, 2016 11:19 AM
  • Hi ElenaLenchic,

    According to your description, this issue appeared when loading most popular package. In my side, I opened Bower search many times and I have not encountered this issue. My version of edge is 25.10586.0.0. I suggest you should update the Edge browser to the latest version. Then try to use it again.

    If the version of Edge already the latest, I think this issue may be related to the compatibility between Edge and Bower, I suggest that you should feedback this issue to Bower search issue collection site too.

    The engineers will evaluate this issue seriously.

    Sincerely,

    Oscar


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place. Click HERE to participate the survey.

    Monday, September 5, 2016 2:13 AM
    Moderator
  • I am currently using IE11. Bower guys say that do not use Visual Studio so they haven't tested the compatibility. 

    When I am browsing sites directly from Visual Studio I get an error (I.e. browsing GitHub) that this site supports only latest versions of IE. [https://github.com/bower/bower.github.io/issues/264?_pjax=%23js-repo-pjax-container]

    I've posted a question to Bower [https://github.com/bower/bower.github.io/issues/264?_pjax=%23js-repo-pjax-container]

    Unfortunately I do not have a permission to post images. Otherwise I would attach a screenshot.

    • Proposed as answer by qing__Moderator Thursday, September 8, 2016 3:34 AM
    • Unproposed as answer by qing__Moderator Thursday, September 8, 2016 1:03 PM
    Monday, September 5, 2016 11:16 AM
  • Hi ElenaLenchic,

    In my side, I use IE10 and VS2015 Enterprise, I could browse the site in VS directly without problems. But the site reminds me to use the latest IE. Please refer to the following screenshot:

    You could upload the screenshot to OneDrive and share a link here.

    Sincerely,

    Oscar


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place. Click HERE to participate the survey.

    Monday, September 5, 2016 2:51 PM
    Moderator
  • They fixed the problem with IE11, but in Visual Studio serch results are displayed only partially.
    Thursday, September 8, 2016 12:10 PM
  • Hi ElenaLenchic,

    In my side I have encountered the same issue, we need to be patient and wait for the engineers to evaluate the issue.

    Sincerely,

    Oscar


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place. Click HERE to participate the survey.

    Friday, September 9, 2016 9:42 AM
    Moderator
  • Ok. Let's wait for the engineers.
    Monday, September 12, 2016 1:13 PM
  • Hi Oscar,

    Any further updates on this? I'm still experiencing the issue even with latest VS updates installed.

    Thanks,

    Dmitry

    Friday, September 30, 2016 10:35 AM