none
Installing an add-in built with VS2013/ .NET4.5 on a machine that has .NET4.0 RRS feed

  • Question

  • Is it possible to install an Outlook 2013 add-in built with VS2013/ .NET4.5 on a machine that has .NET4.0? I get the following message when I try to run the install.exe : "Add-in requires the following items to be installed on your computer. Click install to begin installing these requirements." and it lists .NET Framework 4.5 Full as a req.

    I ask because this will be deployed to many users who all already have .NET4.0 on their machines.

    Tuesday, December 1, 2015 8:57 PM

Answers

  • Hi Luke,

    Thank you for posting in MSDN forum.

    You could install .NET Framework 4.5 which has .NET Framework 4.0.

    Here is the .NET Framework 4.5 download link:

    https://www.microsoft.com/en-us/download/details.aspx?id=48130


    Here are some common install tips of .NET Framework installation:
    ·         Turn off your anti-virus/antispyware software during installation
    ·         Install the latest Windows updates from the Windows Update site
    ·         Complete or dismiss Windows Update before installation. (and don't forget to turn it on later)
    ·         If the installation fails, you can collect the setup log file and analyze them.


    You can follow below steps to collect log files:
    1.       Try to go to your "%temp%" folder (Start Menu >>Run >> Type "%temp%).
    2.       Manually filter the .net framework logs from "%temp%" folder .

    Please upload the file to https://skydrive.live.com/ and share the link here

     

    Best Regards,

    Wen Xu


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.

    Click HERE to participate the survey.

    Wednesday, December 2, 2015 8:15 AM
    Moderator