none
Exception reading manifest from http://localhost/test/BLBank.svc: the manifest may not be valid or the file could not be opened. RRS feed

  • Question

  • hi i m deploying my WCF web service on Windows server 2008 R2 and i m getting the following error when i m browsing my web service.

    The Detailed error message as blow.
    PLATFORM VERSION INFO
     Windows    : 6.0.6002.131072 (Win32NT)
     Common Language Runtime  : 2.0.50727.4200
     System.Deployment.dll   : 2.0.50727.4016 (NetFxQFE.050727-4000)
     mscorwks.dll    : 2.0.50727.4200 (NetFxQFE.050727-4200)
     dfdll.dll    : 2.0.50727.4016 (NetFxQFE.050727-4000)
     dfshim.dll    : 2.0.50727.4016 (NetFxQFE.050727-4000)

    SOURCES
     Deployment url   : http://localhost/test/BLBank.svc

    ERROR SUMMARY
     Below is a summary of the errors, details of these errors are listed later in the log.
     * Activation of http://localhost/test/BLBank.svc resulted in exception. Following failure messages were detected:
      + Exception reading manifest from http://localhost/test/BLBank.svc: the manifest may not be valid or the file could not be opened.
      + Name cannot begin with the '%' character, hexadecimal value 0x25. Line 1, position 2.

    COMPONENT STORE TRANSACTION FAILURE SUMMARY
     No transaction error was detected.

    WARNINGS
     There were no warnings during this operation.

    OPERATION PROGRESS STATUS
     * [12/4/2009 1:45:34 PM] : Activation of http://localhost/test/BLBank.svc has started.

    ERROR DETAILS
     Following errors were detected during this operation.
     * [12/4/2009 1:45:34 PM] System.Deployment.Application.InvalidDeploymentException (ManifestParse)
      - Exception reading manifest from http://localhost/test/BLBank.svc: the manifest may not be valid or the file could not be opened.
      - Source: System.Deployment
      - Stack trace:
       at System.Deployment.Application.ManifestReader.FromDocument(String localPath, ManifestType manifestType, Uri sourceUri)
       at System.Deployment.Application.DownloadManager.DownloadDeploymentManifestDirectBypass(SubscriptionStore subStore, Uri& sourceUri, TempFile& tempFile, SubscriptionState& subState, IDownloadNotification notification, DownloadOptions options, ServerInformation& serverInformation)
       at System.Deployment.Application.DownloadManager.DownloadDeploymentManifestBypass(SubscriptionStore subStore, Uri& sourceUri, TempFile& tempFile, SubscriptionState& subState, IDownloadNotification notification, DownloadOptions options)
       at System.Deployment.Application.ApplicationActivator.PerformDeploymentActivation(Uri activationUri, Boolean isShortcut, String textualSubId, String deploymentProviderUrlFromExtension, BrowserSettings browserSettings, String& errorPageUrl)
       at System.Deployment.Application.ApplicationActivator.ActivateDeploymentWorker(Object state)
      --- Inner Exception ---
      System.Xml.XmlException
      - Name cannot begin with the '%' character, hexadecimal value 0x25. Line 1, position 2.
      - Source: System.Xml
      - Stack trace:
       at System.Xml.XmlTextReaderImpl.Throw(Exception e)
       at System.Xml.XmlTextReaderImpl.ParseQName(Boolean isQName, Int32 startOffset, Int32& colonPos)
       at System.Xml.XmlTextReaderImpl.ParseElement()
       at System.Xml.XmlTextReaderImpl.ParseDocumentContent()
       at System.Deployment.Application.ManifestValidatingReader.XmlFilteredReader.Read()
       at System.Xml.XmlCharCheckingReader.Read()
       at System.Xml.XsdValidatingReader.Read()
       at System.Deployment.Application.ManifestReader.FromDocument(String localPath, ManifestType manifestType, Uri sourceUri)

    COMPONENT STORE TRANSACTION DETAILS
     No transaction information is available.

     

    Friday, December 4, 2009 8:36 AM

All replies

  • Greetings Umesh,

    Could you please confirm, How do you deploy the WCF service. By publishing it from VS or by MSI or Clickonce? So that i can analyze your issue further and suggest you accordingly for further action.

    Looking forward for your response.

    Thanks & Regards,
    Harish


    Monday, January 4, 2010 7:22 PM
  • Hi Umesh,

    Could You please confirm if this is failing on only one machine or every machine?

    Also, please let us know the method with which you are deploying this app.



    Thanks,
    Aditya Hari
    Monday, January 4, 2010 11:06 PM
  • Umesh,

    Could you please respond on the previous reply to your thread, we need your inputs to proceed further to resolve your issue.

    Kindly let us know for further action on your issue.

    Regards,
    Harish
    Thursday, January 14, 2010 3:30 PM