locked
Program Compatibility Assistant problem RRS feed

  • Question

  • Now,I am using Visual Studio 2005 professional edition in my laptop.I am using Window Vista Home Premium.Program Compatibility Assistant Dialog appears when I open Visual Studio 2005 .So,I choose Check for solutions Online.Window compatibility problem found dialog box appears.How to solve this problem?Pls give me advice.

    Thanks and Regards

    Nwe Nwe

    • Moved by Konrad Neitzel Tuesday, December 11, 2012 12:44 PM (From:Developer Documentation and Help System)
    Tuesday, December 11, 2012 9:24 AM

Answers

  • Hi New,

    About how to prevent the Program Compatibility Assistant from appearing on Windows Vista. You can refer to:http://blogs.msdn.com/b/astebner/archive/2007/05/17/2705372.aspx

    Or you can use those registry keys to disable the Program Compatibility Assistant warning on other computers. To do this, follow these steps indicated below:

    1.Run the affected program on a test computer.

    2.When you receive the Program Compatibility Assistant warning message, click to select the Don't show this message again check box.
    This above action creates a registry entry in the following registry subkey:
    HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows NT\CurrentVersion\AppCompatFlags
    The name of the entry is the GUID that represents the program entry in the Appcompat database. The entry type is DWORD, and the entry has a value of 0x77.

    3.Exit the program.

    4.Save the registry entry that was created in step 2.

    5.In the installation script, include steps to add the registry entry before the installation starts.

    More information you can refer to:

    http://blogs.msdn.com/b/smondal/archive/2012/08/05/how-to-work-around-the-program-compatibility-assistant-warning-in-visual-studio-unattended-setup.aspx

    Best regards,


    Ego [MSFT]
    MSDN Community Support | Feedback to us
    Develop and promote your apps in Windows Store
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    • Proposed as answer by Ego Jiang Wednesday, December 12, 2012 3:19 AM
    • Marked as answer by Ego Jiang Monday, December 17, 2012 8:26 AM
    Wednesday, December 12, 2012 3:19 AM

All replies

  • Hi,

    I am moving this thread to the Visual Studio Setup and Installation forum for better support.

    With kind regards,

    Konrad


    Tuesday, December 11, 2012 12:43 PM
  • Hi New,

    About how to prevent the Program Compatibility Assistant from appearing on Windows Vista. You can refer to:http://blogs.msdn.com/b/astebner/archive/2007/05/17/2705372.aspx

    Or you can use those registry keys to disable the Program Compatibility Assistant warning on other computers. To do this, follow these steps indicated below:

    1.Run the affected program on a test computer.

    2.When you receive the Program Compatibility Assistant warning message, click to select the Don't show this message again check box.
    This above action creates a registry entry in the following registry subkey:
    HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows NT\CurrentVersion\AppCompatFlags
    The name of the entry is the GUID that represents the program entry in the Appcompat database. The entry type is DWORD, and the entry has a value of 0x77.

    3.Exit the program.

    4.Save the registry entry that was created in step 2.

    5.In the installation script, include steps to add the registry entry before the installation starts.

    More information you can refer to:

    http://blogs.msdn.com/b/smondal/archive/2012/08/05/how-to-work-around-the-program-compatibility-assistant-warning-in-visual-studio-unattended-setup.aspx

    Best regards,


    Ego [MSFT]
    MSDN Community Support | Feedback to us
    Develop and promote your apps in Windows Store
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    • Proposed as answer by Ego Jiang Wednesday, December 12, 2012 3:19 AM
    • Marked as answer by Ego Jiang Monday, December 17, 2012 8:26 AM
    Wednesday, December 12, 2012 3:19 AM