The following forum(s) are migrating to a new home on Microsoft Q&A (Preview): Azure Virtual Machines!

Ask new questions on Microsoft Q&A (Preview).
Interact with existing posts until December 13, 2019, after which content will be closed to all new and existing posts.

Learn More

 none
Cannot RDP to VM RRS feed

  • Question

  • http://social.msdn.microsoft.com/Forums/en-US/WAVirtualMachinesforWindows/thread/9c88a364-c3eb-41aa-a6b0-3ceae00491c2

    I can no longer RDP to my VM.

    The authentication continually fails.

    I have ran into this problem now w/ 2 separate Vms.

    I have tried changing the port, reprovisioning, etc…NOTHING WORKS!

    Thanks for any help!

    Saturday, January 26, 2013 9:40 PM

Answers

  • Hi,

    • Did you ever successfully RDP to that new VM?
    • Does this PowerShell command return True when you try connecting to the port? The IP will be the virtual IP under Quick Glance, and the port is the Public Port of the RDP endpoint (which by default will NOT be 3389).

      (New-Object System.Net.Sockets.TcpClient("<virtual IP>", <RDP public port>)).client.connected

      For example:

      (New-Object System.Net.Sockets.TcpClient("168.x.y.z",54321)).client.connected
    • Does the VM restart successfully, but still no RDP access?
    • Can you try connecting to it from a different location? For example if you are behind a corporate firewall, can you try getting to it from a computer that isn't behind that firewall?

    Thanks,


    Friday, February 1, 2013 8:42 AM
    Moderator