locked
insufficient permissions error in SQL 2008 RS RRS feed

  • Question

  • I installed SQL 2008 with RS in native mode, installed sharepoint 3.0 (front-end only, new farm), installed Reporting services add-in for sharepoint technologies, on a server 2008 server.

    I get following error The permissions granted to user 'mydomain\user' are insufficient for performing this operation. (rsAccessDenied) However this is only when I try to access the reportserver (http://myserver/reportserver). I have no problem accessing the reporting database through SQL Management studio (with the same account / credentials) or with accessing reportmanager (http://myserver/Reports), also with the same account. The account is a domain account with unlimited access (administrator account). I do not have the same problem with another (built-in) domain account 'Administrator'. Also when I use a local administrator account I can access the reportserver. Why? How to change?

    Also I tried logging off and logging into Windows with a local administrator account. In that case I can login to reportserver with the same domain account that doesn't work when I'm logged into Windows with that domain account. I also tried logging into Windows with the domain administrator account. In that case I can also log into reportserver with both domain accounts. So the problem is only when logged into Windows with this one account and then logging into reportserver with the same account.

    Before this I did the installation (all in test environment) with SQL in sharepoint integrated mode. I didn't have this problem then, as far as I am aware I used exactly the same user account credentials.


    R.
    • Edited by ruud00000 Tuesday, July 28, 2009 8:19 AM
    Tuesday, July 28, 2009 7:54 AM

Answers

All replies

  • Wednesday, July 29, 2009 9:58 AM
  • I found a lot of discussion there. I tried this :

    ::
    Not sure it applies to everyone, but if you are running Report Services on Vista or Windows Server 2008 you MUST follow Microsoft's additional configurations. They are in the Books Online under Reporting Services. Search for How to: Configure a Report Server for Local Administration on Windows Vista and Windows Server 2008
    The short summary:
    IE 7 does not pass Admin privileges forward.
    Primary step: Start IE using Run as administrator
    Then add your local host to the Trusted Sites list in IE.
    Browse to http://localhost/reports (check your config for URL)
    Click Permissions tab. Add a new role. Add your personal account. Give yourself Content Manager role.
    Click the Site Settings link in the top-right corner.
    Select Security.
    Add new role assignment to your accounting, giving yourself System Administrator role.
    Now close browser and see if you can connect as yourself.

    Is this what you meant? Looks like it worked for me.


    R.
    Wednesday, July 29, 2009 8:03 PM