locked
Validation error 3117: We were unable to unpack the APPX package RRS feed

  • Question

  • I'm trying to submit my first Windows Phone app which was build in VS 2013 Update 2 and is a WP8.1 project. There is nothing complicated about my app, no dependencies on databases etc. as it's most a web app with native controls. I have followed these steps:

    1. In App Manifest I sign the Assembly with a key file I created (even if I don't sign it I still get the same issue)
    2. I then click on Project > Store > Associate App with Store and this runs fine.
    3. I click on Build > Rebuild Solution just to make sure
    4. Once done I click on Project > Store > Create App Packages
    5. I select my App Name which I reserved a day or so ago
    6. I set my version number (doesn't matter what version number I use for this either - same issues)
    7. I select Neutral as the architecture (tried with just ARM as well but no luck)
    8. Select the tickbox to include public symbol files (doesn't matter if this is selected or not still get error)
    9. Click create button and all goes successfully
    10. I then click Launch Windows App Certification Kit (version 3.3) and my app passes all the validation tests
    11. I click on Project > Store > Upload App Packages which takes me direct to the my app in Windows Phone Dev Center
    12. I Click on Complete and then on Add New when in the upload and describe your package page
    13. Upload is perfect but just after upload is 100%, when it says Loading info for your packages it bombs out and returns the 3117 error.

    Is this a bug or am I missing something here?

    Wednesday, April 23, 2014 4:59 PM

Answers

  • Oh my goodness, turns out that the only way to fix this is between 6 & 7 I had to select "Never" create app package and then it was able to upload the app and unpack it.
    • Marked as answer by justinhartman Wednesday, April 23, 2014 6:32 PM
    Wednesday, April 23, 2014 5:19 PM

All replies

  • Oh my goodness, turns out that the only way to fix this is between 6 & 7 I had to select "Never" create app package and then it was able to upload the app and unpack it.
    • Marked as answer by justinhartman Wednesday, April 23, 2014 6:32 PM
    Wednesday, April 23, 2014 5:19 PM
  • I was befuddled by that error also.  I tried several other things, but changing the "Generate app bundle" to never worked for me too.  Thanks for figuring it out!
    Saturday, April 26, 2014 4:31 PM