none
Updated ResourceHyperlinkAddress doesn't appear in Reporting Database view MSP_EpmResource_UserView RRS feed

  • Question

  • Hi,

    I use MS Project 2010.

    I have a problem with the reporting database MSP_EpmResource_UserView. The value for ResourceHyperlinkHref is null, even though I can see it in PWA (web browser) for a specific resource. I've verified and it exists in the published database. Is this a bug, or shall I look somewhere else in Reporting Database to retrieve this information?

    The ResourceHyperlink field is set also, but this one is set correctly in the Reporting DB.

    I'm adding resources from a console application developed in C#, using PSI.

    This is from Reporting DB:

    ReportingDB PrintScreen

    This is from Published DB:

    On request I can provide also the screenshot from PWA

    Thank you,

    Vlad

    Monday, January 13, 2014 10:21 AM

Answers

  • The Hyperlink Address field contains the address for a hyperlink associated with a task, resource, or assignment.

    The Hyperlink Href field contains the combination, or concatenation, of the Hyperlink Address and Hyperlink SubAddress fields associated with a task, resource, or assignment.

    The Hyperlink SubAddress field contains the specific location in a document in a hyperlink associated with a task, resource, or assignment.

    As per your image i can see Res_Hyperlink_SUB_Address is Null add any link in the filed then publish the project plan again and check .

    You also check if your Reporting DB is not in sync  with Publish DB then 

    go to Manage Project Web Apps and start an Administrative Backup of Enterprise Custom Fields and their Administrative Restore, as you found for 2010. And it is the same here: a Reporting Database refresh will be started and it takes some time. So try to start outside normal working hours. And be patient, add Job Completion State "Success" to queue, to see that someting is done.

    or 

    http://pwmather.wordpress.com/2011/07/15/projectserver-2010-reporting-sync-job-failed-foreign-key-constraint-ps2010-project/


    kirtesh


    • Edited by Kirteshtiw Monday, January 13, 2014 11:40 AM
    • Marked as answer by dovle88 Wednesday, January 15, 2014 12:40 PM
    Monday, January 13, 2014 11:37 AM

All replies

  • The Hyperlink Address field contains the address for a hyperlink associated with a task, resource, or assignment.

    The Hyperlink Href field contains the combination, or concatenation, of the Hyperlink Address and Hyperlink SubAddress fields associated with a task, resource, or assignment.

    The Hyperlink SubAddress field contains the specific location in a document in a hyperlink associated with a task, resource, or assignment.

    As per your image i can see Res_Hyperlink_SUB_Address is Null add any link in the filed then publish the project plan again and check .

    You also check if your Reporting DB is not in sync  with Publish DB then 

    go to Manage Project Web Apps and start an Administrative Backup of Enterprise Custom Fields and their Administrative Restore, as you found for 2010. And it is the same here: a Reporting Database refresh will be started and it takes some time. So try to start outside normal working hours. And be patient, add Job Completion State "Success" to queue, to see that someting is done.

    or 

    http://pwmather.wordpress.com/2011/07/15/projectserver-2010-reporting-sync-job-failed-foreign-key-constraint-ps2010-project/


    kirtesh


    • Edited by Kirteshtiw Monday, January 13, 2014 11:40 AM
    • Marked as answer by dovle88 Wednesday, January 15, 2014 12:40 PM
    Monday, January 13, 2014 11:37 AM
  • Thanks Kirtesh for the solution. I've solved it by settings the Hyperlikn Subaddress field to empty string.

    I expected that the Hyperlink Subaddress field null value would be treated as a empty string by default, but it seams that it doesn't work like this

    Wednesday, January 15, 2014 12:43 PM