none
What is the correct service start configuration for a NDIS protocol driver? RRS feed

  • Question

  • For some reason NDIS does not seem to recognize my driver when I set its service start configuration to boot or autostart, since I do not receive any packets. However, as demand start it works perfectly!

    The driver is Test signed, could that be it?

    It is configured in the NDIS group load order.

    Using Windows 7 on test mode and Visual Studio 2012 for development.


    • Edited by RzRDigo Wednesday, February 4, 2015 5:25 PM
    Wednesday, February 4, 2015 5:24 PM

Answers

  • NDIS itself doesn't know anything about signatures or start type (boot/demand).  Those are all handled at a lower level, in the kernel.  As long as your driver is loaded somehow, NDIS is happy to use it.
    Thursday, February 5, 2015 3:07 AM

All replies

  • NDIS itself doesn't know anything about signatures or start type (boot/demand).  Those are all handled at a lower level, in the kernel.  As long as your driver is loaded somehow, NDIS is happy to use it.
    Thursday, February 5, 2015 3:07 AM
  • Why do I not receive any packets when it is started as autostart or boot then?
    Pnpevents and everything else works...
    Thursday, February 5, 2015 5:25 PM
  • Because to start the driver you need administrator rights, and for our final product it would be best if only the installer was run as administrator, not the control application
    Thursday, February 5, 2015 5:27 PM
  • I don't know.  There's some other issue here.  I'm only saying that the issue is not that NDIS disagrees with your driver's code signature or with how it was started.  If everything else works except datapath, I'd be suspicious that OID_GEN_PACKET_FILTER didn't go down correctly. Check with !ndiskd.miniport -filterdb to see if the receive path is enabled on your protocol.
    Friday, February 6, 2015 12:32 AM
  • I did check that the Oid request returns successfully, does that not mean that it was set correctly?
    Monday, February 9, 2015 6:27 PM