locked
E-mail's not sending to approvers RRS feed

  • Question

  • When I assign a document to be approved,  the task gets assigned to the approver correctly and this shows up in the workflow.

    I instantly get an e-mail starting that the workflow has started, however the approver does not get an e-mail.

    If someone starts working on the workflow after being verbally told to do so, all the e-mails such as overdues come in all at once.

     

    Any ideas?

    Moss 2007 sp2

    Thursday, February 17, 2011 10:00 AM

Answers

  • Hi,

     

    According to my understanding, your requirement is that the tasks are assigned correctly to approvers, but no emails are sent to them. I suppose someone would be modified the workflow task with SharePoint accidentally. I suggest that you should have a try to reconfigure this task.

    You edit the exit workflow:

    Settings-> List Settings-> Workflow Settings

    From the workflow settings page, I selected "New Task List" for the Tasks and History options.  This created new the new Task and History list and associated them with the workflow.  I then opened the new task list and then verified that the "Send Email" option was enabled on the new Task List.  Settings -> List Settings -> Advanced Settings -> Email Notification->”Yes”. Run your test.

     
    Best regards
    David Hu

     

    • Marked as answer by Peng Lei Friday, February 25, 2011 9:24 AM
    Monday, February 21, 2011 5:55 AM

All replies

  • Hey rbansky,

    Is this a custom workflow or the OOTB approval workflow?

    Thanks!

    Tom


    Tom Molskow - SharePoint Architect - Microsoft Community Contributor 2011 Award - Linked-In - SharePoint Gypsy
    Thursday, February 17, 2011 9:48 PM
  • Hi,

     

    According to my understanding, your requirement is that the tasks are assigned correctly to approvers, but no emails are sent to them. I suppose someone would be modified the workflow task with SharePoint accidentally. I suggest that you should have a try to reconfigure this task.

    You edit the exit workflow:

    Settings-> List Settings-> Workflow Settings

    From the workflow settings page, I selected "New Task List" for the Tasks and History options.  This created new the new Task and History list and associated them with the workflow.  I then opened the new task list and then verified that the "Send Email" option was enabled on the new Task List.  Settings -> List Settings -> Advanced Settings -> Email Notification->”Yes”. Run your test.

     
    Best regards
    David Hu

     

    • Marked as answer by Peng Lei Friday, February 25, 2011 9:24 AM
    Monday, February 21, 2011 5:55 AM