none
Site Workflow Initiation Fomrs on Document Center Site

    Question

  • I cannot create even the most basic site workflow on a site created with the Document Center template. The problem is the initiation form.  It will switch to a page with WFInitForm in big letters at the top, but no info from the form or the okay button.  I made a new document center site to test if there was an issue with the site.  Even a fresh Document Center site has the same problem.  The workflow test was very simple and I tried different workflows, so I think it may be yet another random restriction Microsoft has put in place.  Has anyone else had this issue?

    Many Thanks, JP

    Tuesday, March 7, 2017 2:08 PM

All replies

  • Hi JP- need more info. Is this a designer workflow? Any customizations on the form?

    cameron rautmann

    Tuesday, March 7, 2017 2:15 PM
  • A workflow created in SharePoint Designer 2013

    Form is super basic.  Just a yes no box.  The original form in the Workflow I am writing had a few more fields.  I decided to create a new super basic workflow with a very simple initiation form to test.  Got the same result mentioned in my original post.  Thanks for looking at this. 


    Many Thanks, JP

    Tuesday, March 7, 2017 6:08 PM
  • Not sure what you mean by the original form in the workflow. What form are you referring to? I'm not able to access your link. Did you make the form using Designer? Can you provide a screenshot and your workflow?

    cameron rautmann

    Tuesday, March 7, 2017 6:46 PM
  • Sorry, that's not  link.  I just cut and pasted the text.  It turns out it is a link to itself, so it just displays the same text on the page instead of the initiation form fields.  Sorry to confuse the matter.  I had a workflow that wasn't working (the original workflow), so I created a super simple workflow to see if the problem is with the workflow, or with something on the site.  It appears to be something with the site.  So weather it is a site setting that needs to change, or restriction Microsoft has set in the architecture, I don't know.

    I have a teamsite where workflows with initiation forms work fine.  A subsite to the teamsite is a document centere site and this is where the initiation forms don't work.


    Many Thanks, JP

    Tuesday, March 7, 2017 7:08 PM
  • I did an additional test with creating a simple workflow on the teamsite where I had a working site workflow with a functioning initiation form.  The new test workflow initiation form has the same problem and does not work.  I looked a the code of the initiation form and it is very short.  It is missing all the stock info that every initiation form has for some reason.  The names of the initiation forms are the same for every workflow.  I thought they would have different names based on the name of the workflow as described in https://support.office.com/en-us/article/Create-a-workflow-initiation-form-26879578-a62b-4fef-8b7e-9e4400afc94b?ui=en-US&rs=en-US&ad=US

    Not sure if this is the issue, or if something has been corrupted in SPD.  Doing more tests to try and figure this out.


    Many Thanks, JP

    Wednesday, March 8, 2017 4:53 PM