none
Installing 3.5 sp1 RRS feed

  • Question

  • I'm running XP.

    Every time I try to install 3.5 sp1, this message comes up.

    [10/28/09,21:08:13] Microsoft .NET Framework 3.0 SP2 x86: [2] Error: Installation failed for component Microsoft .NET Framework 3.0 SP2 x86. MSI returned error code 1603
    [10/28/09,21:08:23] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.0 SP2 x86 is not installed.


    I've looked everywhere and can't find a DL for 3.0 sp2.

    I've tried about 3 solutions and none work.

    - Updating (can't find the update needed for 3.0 sp2)
    - Changing the permissions in the security path in regedit to full.
    - Reinstalling everything and cleaning them up.


    I don't have 3.0 sp1 installed, if that is needed tell me please.


    Thanks.
    Thursday, October 29, 2009 12:12 AM

Answers

  • THANKS FOR READING.

    This issue has been solved randomly.



    I'll post what I did.


    I went to C://Windows -> Properties -> Security -> Advanced
    Then I went to the Owners Tab
    Selected Administrator, cliked apply.


    Then I installed 3.5sp1 And it worked.


    • Changed type Untouch Friday, October 30, 2009 10:54 PM solved
    • Merged by YiChun Chen Monday, November 2, 2009 11:06 AM Solution
    • Marked as answer by YiChun Chen Monday, November 2, 2009 11:13 AM
    Friday, October 30, 2009 10:05 PM

All replies

  • Hi

    U can refer this link for .net framework 3.5 sp1
    http://msdn.microsoft.com/en-us/netframework/aa569263.aspx
    It has bootstrapper and full package
    Make sure u are logged in as administrator otherwise .net framework or sp1 doesn't install properly ....

    Also plz check whether u have .Net Framework 3.5 installed properly

    There is difference between .Net Framework 3.5 SP1 and .Net Framework 3.5
    SP1 is service pack 1
    . A service pack (in short SP) is a collection of updates, fixes and/or enhancements to a software program delivered in the form of a single installable package

    .Net Framework 3.5  is .Net Framework version 3.5 :-
    The Microsoft .NET Framework is a software framework that can be installed on computers running Microsoft Windows operating systems. It includes a large library of coded solutions to common programming problems and a virtual machine that manages the execution of programs written specifically for the framework. The .NET Framework is a Microsoft offering and is intended to be used by most new applications created for the Windows platform.

    Use Verification Tool ( http://blogs.msdn.com/astebner/pages/8999004.aspx ) to verify .Net Framework and let me know the status of which frameworks u already have on your machine ?


    also try these methods

    Aaron Stebner's WebLog
    NET Framework Troubleshooting Guide:
    http://blogs.msdn.com/astebner/articles/454956.aspx

    It if very hard to say the root cause of the issue without checking the
    install log. But with MSDN troubleshooting experience you can try the below
    steps:

    1. Run the MS cleanup tool ; msicuu2.exe

    2. After cleanup has completed.

    3. Browse to folder c:\Windows and delete the Folder name Microsoft.Net

    4. Browse to folder c:\windows\system32 look for a file name mscoree.dll and
    see if it is available, and if you find that delete it

    5. Click Start > Run > Type Regedit > Ok > HKEY_LOCAL_MACHINE > SOFTWARE >
    MICROSOFT > Delete the key .Netframework

    6. Rename the folder C:\MSOCache C:\MSOCache_old

    6. Restart the computer

    ================

    1. Click Start Run Type %temp% delete all the files there after you sort by
    date modified and you might not able to delete some file which you can
    ignore

    2. Open a notepad and copy the as it is below and the save it as
    verbose.reg

    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Win dows\Installer]

    "EnableAdminTSRemote"=dword:00000001

    "Logging"="voicewarmup"

    3. Once the registry key is created double click on that and at the prompt
    say yes

    4. This verbose logging will create the log file an will help MSDN to find
    the cause

    5. Run the installation of frame work. If it installs you are finished. If
    not send the log files which will get created in the Temp folder with name
    as MSI. Zip those files and  upload ur zip files to www.skydrive.live.com
    and Post the link back here



    Thanks
    anliS


    Best Regards,
    anliS
    BIC
    Please remember to mark the correct replies as answers
    Thursday, October 29, 2009 9:29 AM
  • Thanks for replying but i'm still having trouble.

    I'm trying to install 3.0 now and it's saying
    WapUI: [2] DepCheck indicates Windows Communication Foundation is not installed.


    :S

    FIXED THAT PROBLEM and now i'm having another 1, trying an update though.
    Thursday, October 29, 2009 7:18 PM
  • Now i'm stuck with nothing.

    I can't install 3.0.

    I cant install any of the others.

    I can't do anything.


    Considering linux at this point.


    Ok somehow I installed 3.5 without 3.0.

    Trying sp1 now

    Nope.

    About ready to give up.
    Friday, October 30, 2009 1:50 AM
  • Hi Untouch,

    Welcome to MSDN forums. And thank you for your post. I can understand your worries on this issue. Let's start from here. :)

    Before the installation, I would suggest you to check the system requirements of .NET 3.5 installation.
    Please see: http://msdn.microsoft.com/en-us/library/bb882520.aspx

    Then please try the following steps for further troubleshooting:
    - Use Cleanup Tool to remove .NET 3.5 >> 3.0 >> 2.0 in order
    - Download .NET Framework 3.5 Service Pack 1 (Full Package) and install it

    For error code "0x643" (decimal "1603"), it's a common error message which means "fatal error during installation".
    Log files may tell us some helpful information.

    If the problem still exists, please try to use collect tool to collect the log files of .NET Framework 3.5 SP1 from your "%temp%" folder?
    http://blogs.msdn.com/heaths/archive/2008/05/09/visual-studio-and-net-log-collection-utility.aspx

    You can upload your log files to SkyDrive and post the link back here.

    Steps:
    - Try to clean your "%temp%" folder (Start menu >> Run... >> Type "%temp%")
    - Install .NET Framework 3.5 Service Pack 1 (Full Package)
    - Collect the logs from "%temp%" folder
    - Upload vslogs.cab file

    Hope this helps. If you have any concern, please feel free to let me know.

    Best regards,
    Yichun Chen

    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    • Edited by YiChun Chen Friday, October 30, 2009 9:22 AM typo
    Friday, October 30, 2009 9:21 AM
  • THANKS FOR READING.

    This issue has been solved randomly.



    I'll post what I did.


    I went to C://Windows -> Properties -> Security -> Advanced
    Then I went to the Owners Tab
    Selected Administrator, cliked apply.


    Then I installed 3.5sp1 And it worked.


    • Changed type Untouch Friday, October 30, 2009 10:54 PM solved
    • Merged by YiChun Chen Monday, November 2, 2009 11:06 AM Solution
    • Marked as answer by YiChun Chen Monday, November 2, 2009 11:13 AM
    Friday, October 30, 2009 10:05 PM
  • This can be an issue with the permission with the ServiceModel 3.0.0.0 registry key. Find the below link for more details

    http://codekeep.net/ASPNET/code/snippets/16827/Unable-to-install-NET-Framework-30-35-VS2008-Solution/view.aspx

    Friday, November 6, 2009 5:37 AM