none
WCF Service takes very long time to start up RRS feed

  • Question

  • There are around 300+ endpoints in the WCF Service. When the service is accessed in browser first time it takes around 60 minutes to load.

    Please advise.

    Friday, May 4, 2018 10:11 AM

All replies

  • Hi Deepakbhole,

    It is hard to image you define so many endpoints for the one service.

    I would suggest you reduce the endpont numbers to try whether it will make different result.

    Best Regards,

    Tao Zhou


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Monday, May 7, 2018 2:32 AM
  • Thank you for your answer.

    I have reduced the nomber of end points by creating 3 services. Now the loading time in browser has been reduced to 7 mins, which is acceptable. But it is now taking more than an hour to add  these services as reference in another project.

    Please advise.

    Tuesday, May 15, 2018 6:03 AM
  • Hi Deepakbhole,

    >>But it is now taking more than an hour to add  these services as reference in another project.

    How did you add service reference?

    Could you share us where the time waste?

    Best Regards,

    Tao Zhou


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Wednesday, May 16, 2018 1:38 AM