locked
Visual Studio Team Suite 2008 - Package "Visual Studio Explorers and designers package" has failed to load RRS feed

  • Question

  • Today I uninstalled my 2005 Team Suite and installed 2008 Team Suite. All of the projects in one of my web application solutions converted correctly, however I have a web reference on the web site that fails to compile. When I go to add a new web reference or update the existing web reference I get an error message: "The components required to enumerate Web references are not installed on this computer. Please re-install Visual Studio". I did find this reference to this issue: http://realise-systems.net/blog/iangriggs/ and tried running : devenv /resetskippkgs from the command line.  When I do that I get the message:

     

    Package "Visual Studio Explorers and designers package" has failed to load properly ( GUID = {8D529D3-625D-4496-8354-3DAD630ECC1B} ). Please contact package vendor for assistance. Application restart is recommended, due to possible environment corruption. Would you like to disable loading this package in the future? You may use 'Package "denv /resetskippkps" to re-enable' package loading.

     

    Has anyone else seen this and is there a solution or an upcoming fix or a hot fix that I can install?

     

    Thanks

    Paul

    Sunday, June 8, 2008 12:07 AM

Answers

  • Was getting this error when I tried to add a web reference or service reference:

     

    "The components required to enumerate web references are not installed on this computer"

     

    I ran:

     

    "C:\Program Files\Microsoft Visual Studio 9.0\Common7\IDE\devenv.exe /resetskippkgs" and it worked for me.  Thanks!

     

    • Marked as answer by StevenPo Tuesday, November 11, 2008 11:34 PM
    Friday, June 27, 2008 8:02 PM

All replies

  • This isn't something I've seen, but you might have better luck on this forum:

    http://forums.msdn.microsoft.com/en-US/vssetup/threads/

     

    Which is for setup issues.

     

     

     

    Thursday, June 12, 2008 3:35 PM
  • Was getting this error when I tried to add a web reference or service reference:

     

    "The components required to enumerate web references are not installed on this computer"

     

    I ran:

     

    "C:\Program Files\Microsoft Visual Studio 9.0\Common7\IDE\devenv.exe /resetskippkgs" and it worked for me.  Thanks!

     

    • Marked as answer by StevenPo Tuesday, November 11, 2008 11:34 PM
    Friday, June 27, 2008 8:02 PM
  • Thanks it worked for me too.

     

    Nirmal

     

    Thursday, July 31, 2008 4:33 PM
  • Same, thanks!

    Togar
    Thursday, September 4, 2008 5:01 PM
  • Thanks! Fixed the problem.
    Thursday, September 4, 2008 5:34 PM
  • Joshua Morgan said:

    I ran:

    "C:\Program Files\Microsoft Visual Studio 9.0\Common7\IDE\devenv.exe /resetskippkgs" and it worked for me.  Thanks!

     



    If devenv.exe /resetskippkgs does not work and Source Analysis Tool for C# is installed, try uninstalling this tool. This tool was the cause of the problem on my computer.
    Wednesday, December 24, 2008 9:57 AM
  • Thanks Joshua. I had same issue but your answer fixed the issue.

    Wednesday, June 17, 2009 7:22 AM
  •  

    Thanks Joshua. It worked !!

    Tuesday, April 20, 2010 6:12 AM
  • Thanks alot. it solved the problem of VS2008
    shah
    Wednesday, August 18, 2010 11:58 AM
  • thanks sir
    Tuesday, February 1, 2011 10:25 AM