locked
SDK QuickStart Tutorials + IIS 7 RRS feed

  • Question

  • User246439416 posted

    Hi,

               I changed my OS from Windows XP to Windows 7. I installed .net Framework SDK v2.0. Now i am trying to configure Asp.net Quick Start Tutorial. When i run ConfigSamples.exe in the Log file following details available.


    AM 6:57:22 19 March 2010: [Begin Samples Configuration]
    AM 6:57:23 19 March 2010: [Info] ConfigSamplesDll_DoTasks: Starting
    AM 6:57:23 19 March 2010: [Info] Config_NETSDK_Detect: .NET Framework SDK installation (detecting): SOFTWARE\Microsoft\.NETFramework
    AM 6:57:23 19 March 2010: [Info] Config_NETSDK_Detect: .NET Framework SDK installation (found): SOFTWARE\Microsoft\.NETFramework
    AM 6:57:23 19 March 2010: [Info] ConfigSamplesDll_DoTasksWithGUI: Starting
    AM 6:59:51 19 March 2010: [Info] Config_ASPNET_Detect: ASP.NET installation (detecting): IIS://localhost/W3SVC
    AM 6:59:51 19 March 2010: [Info] Config_ASPNET_Detect: ASP.NET installation (not found): [Info] Config_ASPNET_Detect: ASP.NET installation (not found)
    AM 6:59:51 19 March 2010: [Info] Config_ASPNET_Detect: ASP.NET installation (not found): IIS://localhost/W3SVC
    AM 6:59:51 19 March 2010: [Info] Config_SSE_DNLD_Detect: SQL Express service instance (detecting): MSSQL$SQLEXPRESS
    AM 6:59:52 19 March 2010: [Info] Config_SSE_DNLD_Detect: SQL Express service instance (found): MSSQL$SQLEXPRESS
    AM 6:59:52 19 March 2010: [Info] Config_SSE_INST_Detect: SQL Express service instance (detecting): MSSQL$SQLEXPRESS
    AM 6:59:53 19 March 2010: [Info] Config_SSE_INST_Detect: SQL Express service instance (found): MSSQL$SQLEXPRESS
    AM 6:59:53 19 March 2010: [Info] Config_IIS_Detect: IIS (Internet Information Services) installation (detecting): IIS://localhost/w3svc/1/root,IIS://localhost/w3svc/AppPools
    AM 6:59:53 19 March 2010: [Info] Config_IIS_Detect: IIS (Internet Information Services) installation (found): IIS://localhost/w3svc/1/root,IIS://localhost/w3svc/AppPools
    AM 6:59:54 19 March 2010: [Info] Config_QUICKSTARTDB_Detect: Quickstart Database and User Registration (detecting)
    AM 6:59:55 19 March 2010: [Info] Config_QUICKSTARTDB_Detect: Quickstart Database and User Registration (found)
    AM 6:59:55 19 March 2010: [Info] Config_QUICKSTART_Detect: Quickstart Samples Previous Build (detecting): SOFTWARE\Microsoft\.NETFramework\sdkQuickStartSetupRun
    AM 6:59:55 19 March 2010: [Info] Config_QUICKSTART_Detect: Quickstart Samples Previous Build (not found)
    AM 6:59:56 19 March 2010: [Info] Config_NETSDK_Detect: .NET Framework SDK installation (detecting): SOFTWARE\Microsoft\.NETFramework
    AM 6:59:56 19 March 2010: [Info] Config_NETSDK_Detect: .NET Framework SDK installation (found): SOFTWARE\Microsoft\.NETFramework
    AM 7:04:39 19 March 2010: [Info] Config_ASPNET_Install: ASP.NET QuickStart registration (installing)
    AM 7:04:57 19 March 2010: [Pass] Enabling ASP.Net for QuickStart virtual directory. Command: C:\Windows\Microsoft.NET\Framework\v2.0.50727\aspnet_regiis.exe -ir -enable.
    AM 7:04:57 19 March 2010: [Info] Config_ASPNET_Detect: ASP.NET installation (detecting): IIS://localhost/W3SVC
    AM 7:04:57 19 March 2010: [Info] Config_ASPNET_Detect: ASP.NET installation (not found): [Info] Config_ASPNET_Detect: ASP.NET installation (not found)
    AM 7:04:57 19 March 2010: [Info] Config_ASPNET_Detect: ASP.NET installation (not found): IIS://localhost/W3SVC
    AM 7:04:57 19 March 2010: [Fail] Config_ASPNET_Install: ASP.NET QuickStart registration (failed): ASP.NET QuickStart registration component could not be detected after installation
    AM 7:04:57 19 March 2010: [Begin Samples Rollback]


    Why am i getting Config_ASPNET_Detect: ASP.NET installation (not found)?

    Can you anyone tell me the solution for install.

    Thursday, March 18, 2010 10:09 PM

Answers

  • User-1068078051 posted

    Hi, I hope someone can assist.  I'm trying to install the quickstart tutorials on a vista machine with IIS7 already installed.  when i try to run ConfigSamples.exe, it fails and rolls back.  The log shows that it fails at this point.

    4:21:13 PM Friday, March 19, 2010: [Pass] Config_ASPNET_Install: ASP.NET QuickStart registration (installed)
    4:21:14 PM Friday, March 19, 2010: [Info] Config_IIS_Install: IIS (Internet Information Services) Virtual Directory Registration (installing)
    4:21:14 PM Friday, March 19, 2010: [Info] Config_IIS_Install: Creating IIS QuickStart application pool: QuickStartV20AppPool
    4:21:14 PM Friday, March 19, 2010: [Info] Config_IIS_Install: Skipping IIS QuickStart application pool creation (IIS 6 not detected): QuickStartV20AppPool
    4:21:14 PM Friday, March 19, 2010: [Info] Config_IIS_Install: Removing IIS Virtual Directories: QuickStartv20
    4:21:21 PM Friday, March 19, 2010: [Pass] Config_IIS_Install: Removed IIS virtual directory: QuickStartv20
    4:21:21 PM Friday, March 19, 2010: [Info] Config_IIS_Install: Creating IIS Virtual Directories: QuickStartv20
    4:21:25 PM Friday, March 19, 2010: [Fail] Config_IIS_Install: IIS (Internet Information Services) Virtual Directory Registration (failed): [Fail] Config_IIS_Install: Could not create IIS virtual directory QuickStartv20
    4:21:25 PM Friday, March 19, 2010: [Begin Samples Rollback]


    How do i get passed this error?

    Thanks!

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Friday, March 19, 2010 5:09 PM
  • User1592395488 posted

    MSFT AJAX is aweful, can get anything to load, VS 2008, VS 2010, .NET 2.0, 3.5, 4.0, is this a JOKE@@@ 

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Friday, March 19, 2010 9:39 PM

All replies

  • User-1659704165 posted

    Hi,

    have insatlled IIS in Widow 7

    http://learn.iis.net/page.aspx/28/install-iis-7-on-windows-vista-and-windows-7/

    http://www.howtogeek.com/howto/windows-vista/how-to-install-iis-on-windows-vista/

    then Register asp.net

    Aspnet_regIIS

    and the Run MIS or Installer With Admin Rights.. right click on Installer -->click on run as Admin


    Friday, March 19, 2010 11:28 AM
  • User246439416 posted

    Before Install .net Framework I installed IIS 7. IIS 7 is working fine Even i followed above links only.

    Even i tried with aspnet_regiis -iru - enable. It is not working.

    Any other solution?

    Friday, March 19, 2010 11:43 AM
  • User-1659704165 posted

    what is Error??

    OR


    right click on cmd --> Run as admin --> go path of aspnet_regIIS -i

    Friday, March 19, 2010 11:54 AM
  • User246439416 posted

    The exact error is "(An error has occurred: 0x80004005 Unspecified error" When i search in google i found some information in

    http://weblogs.asp.net/scottgu/archive/2006/09/19/Tip_2F00_Trick_3A00_-Using-IIS7-on-Vista-with-VS-2005.aspx

    But That is not solved my issue.

    Friday, March 19, 2010 12:11 PM
  • User-1068078051 posted

    Hi, I hope someone can assist.  I'm trying to install the quickstart tutorials on a vista machine with IIS7 already installed.  when i try to run ConfigSamples.exe, it fails and rolls back.  The log shows that it fails at this point.

    4:21:13 PM Friday, March 19, 2010: [Pass] Config_ASPNET_Install: ASP.NET QuickStart registration (installed)
    4:21:14 PM Friday, March 19, 2010: [Info] Config_IIS_Install: IIS (Internet Information Services) Virtual Directory Registration (installing)
    4:21:14 PM Friday, March 19, 2010: [Info] Config_IIS_Install: Creating IIS QuickStart application pool: QuickStartV20AppPool
    4:21:14 PM Friday, March 19, 2010: [Info] Config_IIS_Install: Skipping IIS QuickStart application pool creation (IIS 6 not detected): QuickStartV20AppPool
    4:21:14 PM Friday, March 19, 2010: [Info] Config_IIS_Install: Removing IIS Virtual Directories: QuickStartv20
    4:21:21 PM Friday, March 19, 2010: [Pass] Config_IIS_Install: Removed IIS virtual directory: QuickStartv20
    4:21:21 PM Friday, March 19, 2010: [Info] Config_IIS_Install: Creating IIS Virtual Directories: QuickStartv20
    4:21:25 PM Friday, March 19, 2010: [Fail] Config_IIS_Install: IIS (Internet Information Services) Virtual Directory Registration (failed): [Fail] Config_IIS_Install: Could not create IIS virtual directory QuickStartv20
    4:21:25 PM Friday, March 19, 2010: [Begin Samples Rollback]


    How do i get passed this error?

    Thanks!

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Friday, March 19, 2010 5:09 PM
  • User1592395488 posted

    MSFT AJAX is aweful, can get anything to load, VS 2008, VS 2010, .NET 2.0, 3.5, 4.0, is this a JOKE@@@ 

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Friday, March 19, 2010 9:39 PM