none
Weird search behaviour after migration from 2010 to 2013

    Question

  • I have a site collection which was migration from 2010 to 2013.

    After migration was done I ran full crawl.

    I have many sub sites called "Articles" and each site has article code and other information. Article code is in the format "AR-1534" where this 1534 is sequential number.

    If I search "105" then article site having code "AR-105" comes on top of search result which is fine.

    I noticed after code "2934", sites stopped appearing in search results unless I use full code with prefix for e.g. "AR-2934".

    Upon investigation I found out that any sites created before migration comes in search result even if I just use code for e.g. "1120" without "AR-" prefix but for any sites created after migration I have to use "AR-3100" in search to get any result.

    Why is this happening like that?
    Friday, December 16, 2016 8:08 PM

Answers

  • I found the solution.

    1. Go to Site Settings of that site which is not appearing in search results

    2. Click on "Search and Offline Availability"

    3. Select "Always index all Web Parts on this site"

    4. Reset index and do full crawl

    Monday, January 09, 2017 7:26 PM

All replies

  • Hi Frank Martin Consultant,

    Please try to re-index sites and then run a full crawl to see if the issue is resolved.

    1. On the Central Administration page, click Manage service applications.

    2. Click the Search service application for which you want to reset the search index.

    3. On the Search Administration page, under System Status, verify that the Administrative status of the Search service application is Running and not Paused.

    4. On the Search Administration page, in the Crawling section, click Index Reset.

    An article about resetting the search index.

    https://technet.microsoft.com/en-us/library/jj219652.aspx

    Best Regards,

    Linda Zhang


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Monday, December 19, 2016 9:54 AM
    Moderator
  • I found the solution.

    1. Go to Site Settings of that site which is not appearing in search results

    2. Click on "Search and Offline Availability"

    3. Select "Always index all Web Parts on this site"

    4. Reset index and do full crawl

    Monday, January 09, 2017 7:26 PM