none
UserErrorRpCollectionLimitReached but also unable to restore to previous backup! RRS feed

  • Question

  • Hello, I use an Azure VM that runs Windows 10 Pro to run possibly harmful programs and analyse them.

    So, after I run a program I need to restore the VM to a previous backup. I've been doing that regularly for a few weeks, but now I have reached the restore point collection limit and my restore fails. According to Azure, it didn't actually fail, but complete with a warning after the restore job was running for 5 minutes and 35 seconds (successful restore normally takes 20 mins 40 secs). When I start the VM I see that the malware and the after effects are still on the VM so I can't just use that as the new clean snapshot. So now I am stuck with an infected VM that I can't restore to a clean backup.

    I've already read this link: https://docs.microsoft.com/en-us/azure/backup/backup-azure-troubleshoot-vm-backup-fails-snapshot-timeout#usererrorrpcollectionlimitreached---the-restore-point-collection-max-limit-has-reached

    For info, my AzureBackup-RG does not have a lock, so there is no lock to remove like the above link suggests. And I can't clean up the restore point collection because I need to restore my VM to one of those restore points first!

    I've deleted all manual backups from All Resources, but I can't delete previous daily backups. I'm not experienced with using PowerShell scripts and such, so if you suggest something like that please explain it for a beginner as well :)


    Monday, September 9, 2019 5:54 PM

Answers

  • I have worked around it (I think!) by selecting a restore point and instead of Replace Existing I did Create New. Now I have a new VM with the correct contents from my desired restore point.

    I stopped backup from my old VM with deleting all backup data, and created a new custom backup policy for my new VM which makes daily backups but only keeps them for 7 days.

    • Marked as answer by studentonazure Monday, September 9, 2019 7:09 PM
    Monday, September 9, 2019 7:09 PM