none
Office365 - Turn on Project Web App Settings RRS feed

  • Question

  • Hi,

    Here is background. I developed a custom app. and getting error on app activation."Turn on Project Web App Settings"

    1. using Office365 with Project server and SharePoint

    2. Root site is Project server site. 

    3. "Project web app setting" feature is enabled on project site. and there is no issue with my custom app activation. 

    4. But i can't activate my custom Apps on separate team site collections. I got following error "Turn on Project web app settings."

    5. When i go to team site settings features there is feature "Project web app setting". when try to activate giving me error with corelation ID. how can i check the id because i am using O365.

    thanks,

    /Asim


    asim MCTS SharePoint 2007 -WSS 3.0

    Wednesday, May 28, 2014 5:35 PM

Answers

  • Hello,

    The issue is that your app is a Project Server app, this can only be deployed to a site where the Project Web App settings feature is enabled, this is only enabled on a PWA site collection. What app is it, you may need to rethink your app if you need it on a non PWA site collection. What is the reason for trying to deploy a Project Server App to a non Project Web App site collection?

    Paul


    Paul Mather | Twitter | http://pwmather.wordpress.com | CPS

    • Marked as answer by SP Ninja Thursday, May 29, 2014 10:59 PM
    Wednesday, May 28, 2014 11:12 PM
    Moderator

All replies

  • Hi Asim,

    Maybe this is silly, but by default, the "server settings" link do not appear on the PWA home page.

    You have either to edit link in the quick launch menu and add it, or access it from the gear icon in the top right corner of the homepage:


    Hope this helps,


    Guillaume Rouyre, MBA, MCP, MCTS |

    Wednesday, May 28, 2014 6:00 PM
    Moderator
  • Looks like App is looking for PWA settings feature which may not be activated , navigate to site collection features and look for Project Web App Settings feature and activate it 

    Thanks | epmXperts | http://epmxperts.wordpress.com

    Wednesday, May 28, 2014 8:16 PM
    Moderator
  • Hello,

    The issue is that your app is a Project Server app, this can only be deployed to a site where the Project Web App settings feature is enabled, this is only enabled on a PWA site collection. What app is it, you may need to rethink your app if you need it on a non PWA site collection. What is the reason for trying to deploy a Project Server App to a non Project Web App site collection?

    Paul


    Paul Mather | Twitter | http://pwmather.wordpress.com | CPS

    • Marked as answer by SP Ninja Thursday, May 29, 2014 10:59 PM
    Wednesday, May 28, 2014 11:12 PM
    Moderator
  • Hi Paul,

    You are right, now i understand. I will rethink my app architecture. thanks, 


    Asim Nadeem / MCTS SharePoint


    • Edited by SP Ninja Thursday, May 29, 2014 11:03 PM
    Thursday, May 29, 2014 10:59 PM