locked
debug menu item missing RRS feed

  • Question

  • In the debug menu (vb10 express) the "delete all break points" entry is now missing! I have done smothig to remove it?

    I do not know what. Can someone help me get this entry back?

    I have gone to "Restore Hidden Debugger Commands"! I can not drag the "delete all break points icon". When i hit "add" the icon is added to the menu bar

    between "project and "debuh"??  It works, but it should be under "debug"!


    james fleming


    • Moved by eryang Thursday, July 7, 2011 6:00 AM (From:Visual Studio Debugger)
    Wednesday, July 6, 2011 6:35 PM

Answers

  • Hi Jim,

    I've the same, strange that the Moderator has moved you to this forum. It is not in the full versions by the way.

    This is the place to tell it. 

    http://connect.Microsoft.Com

    In the mean time you can use Ctrl Shift F9

    Maybe you can put the link to your connect message in this forum so Express users can vote for it to be made available again.

     


    Success
    Cor
    Thursday, July 7, 2011 7:06 AM
  • Hi jim,

    Debug>Delete All Breakpoints is not visiable under Basic Settings. Please go to Tools--> Settings-->Changed from Basic ---> Expert Settings. Then you will see the option now.

    As Cor suggested, you could also use Ctrl+Shift+F9 to implement the same result.

    Please have a try and let us know the situation on your side.

    Have a nice day.

    Best regards


    Liliane Teng [MSFT]
    MSDN Community Support | Feedback to us
    Get or Request Code Sample from Microsoft
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

     

    • Edited by Liliane Teng Friday, July 15, 2011 2:51 AM
    • Proposed as answer by Cor Ligthert Friday, July 15, 2011 7:43 AM
    • Marked as answer by Liliane Teng Monday, July 18, 2011 9:02 AM
    Tuesday, July 12, 2011 7:40 AM
  • Move to Visual Basic Express Edition forum for better support. 
    Eric Yang [MSFT]
    MSDN Community Support | Feedback to us
    Get or Request Code Sample from Microsoft
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Thursday, July 7, 2011 5:59 AM
  • That's odd, my VB 2010 Express has this command (Debug>Delete All Breakpoints CTL+SHIFT+F9).

    You can, indeed, remove it, but I can't imagine how it could be done by accident. You can restore the menu by:

    1. Right-clicking the menu bar.
    2. select Customize... at the bottom.
    3. Select the Commands Tab.
    4. Select the Menu Bar option, and from the drop-down select the Debug Menu.
    5. Press Reset All.
    6. A confirmation to reset the debug menu should pop up.

    The Delete all Breakpoints should show up on the menu; it'll be grayed out if you don't have any breakpoints.

     

     

     


    Stephen J Whiteley
    Tuesday, July 12, 2011 7:39 PM
  • That's odd, my VB 2010 Express has this command (Debug>Delete All Breakpoints CTL+SHIFT+F9).

    Hi SJWhiteley,

    Thanks for your reply.

    Yes, VB2010 Express has this command. I have found the reason. This option is not visible under Basic Settings. I have edited my first reply. Thank you very much.

    Have a nice day.

    Best regards


    Liliane Teng [MSFT]
    MSDN Community Support | Feedback to us
    Get or Request Code Sample from Microsoft
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Friday, July 15, 2011 2:54 AM

All replies

  • Move to Visual Basic Express Edition forum for better support. 
    Eric Yang [MSFT]
    MSDN Community Support | Feedback to us
    Get or Request Code Sample from Microsoft
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Thursday, July 7, 2011 5:59 AM
  • Hi Jim,

    I've the same, strange that the Moderator has moved you to this forum. It is not in the full versions by the way.

    This is the place to tell it. 

    http://connect.Microsoft.Com

    In the mean time you can use Ctrl Shift F9

    Maybe you can put the link to your connect message in this forum so Express users can vote for it to be made available again.

     


    Success
    Cor
    Thursday, July 7, 2011 7:06 AM
  • Hi jim,

    Debug>Delete All Breakpoints is not visiable under Basic Settings. Please go to Tools--> Settings-->Changed from Basic ---> Expert Settings. Then you will see the option now.

    As Cor suggested, you could also use Ctrl+Shift+F9 to implement the same result.

    Please have a try and let us know the situation on your side.

    Have a nice day.

    Best regards


    Liliane Teng [MSFT]
    MSDN Community Support | Feedback to us
    Get or Request Code Sample from Microsoft
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

     

    • Edited by Liliane Teng Friday, July 15, 2011 2:51 AM
    • Proposed as answer by Cor Ligthert Friday, July 15, 2011 7:43 AM
    • Marked as answer by Liliane Teng Monday, July 18, 2011 9:02 AM
    Tuesday, July 12, 2011 7:40 AM
  • That's odd, my VB 2010 Express has this command (Debug>Delete All Breakpoints CTL+SHIFT+F9).

    You can, indeed, remove it, but I can't imagine how it could be done by accident. You can restore the menu by:

    1. Right-clicking the menu bar.
    2. select Customize... at the bottom.
    3. Select the Commands Tab.
    4. Select the Menu Bar option, and from the drop-down select the Debug Menu.
    5. Press Reset All.
    6. A confirmation to reset the debug menu should pop up.

    The Delete all Breakpoints should show up on the menu; it'll be grayed out if you don't have any breakpoints.

     

     

     


    Stephen J Whiteley
    Tuesday, July 12, 2011 7:39 PM
  • That's odd, my VB 2010 Express has this command (Debug>Delete All Breakpoints CTL+SHIFT+F9).

    Hi SJWhiteley,

    Thanks for your reply.

    Yes, VB2010 Express has this command. I have found the reason. This option is not visible under Basic Settings. I have edited my first reply. Thank you very much.

    Have a nice day.

    Best regards


    Liliane Teng [MSFT]
    MSDN Community Support | Feedback to us
    Get or Request Code Sample from Microsoft
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Friday, July 15, 2011 2:54 AM
  • I have this exact same problem with c# 2010 Express.  None of the above solutions do the trick.   I do have it in Expert mode.   I'm running Windows 7, 64-bit.  Can anyone help?

    Monday, October 8, 2012 4:22 PM
  • Any more bright ideas?

    I'm using Visual C# 2010 Express in Visual Studio 2010 10.0.40219.1 Sp1Rel, and cannot find Debug » Clear All settings either on the menu, in the Debug toolbar or in the Customize dialog. I see no effect from Ctrl +Shift + F9.

    I have applied these settings, checking after each one:

    • Tools » Settings » Expert Settings;
    • Tools » Settings » Reset…;
    • Tools » Customize » Toolbar Debug » Reset All;
    • restart Visual Studio.

    In the Customize Dialog, I see only 2 breakpoint-related items

    • Toggle Breakpoint (F9) - active
      and
    • Enable / Disable Breakpoint - available

    There is an item Clear All, which seems to refer to Data Tips.

    Surely some  MCC / MSFT / MVP / MS-bright-spark can help!


    Thursday, December 20, 2012 12:52 AM